Oil Skimming (二分图)

Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.

Input The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell. Output For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted. Sample Input
1
6
......
.##...
.##...
....#.
....##
......
Sample Output
Case 1: 3

有一个石油大亨要在一片NN区域里面打捞石油,它的网能网住的区域面积是1×2

#代表这个地方是石油,.代表这个地方是海水,问在这一片水域,最多能打捞多少石油(不能石油和海水一起捞)。

先给石油编上号码,编号为:1 2 3 4 5…这种,然后我们遍历这个区域,如果在1×2的区域有石油,那么就给他们的编号加一条边,建立二分图,最后求这个二分图的最大匹配就是答案。

因为建立的是双向边,所以要最后结果除以2

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int N = 650;
char mp[N][N];
int num[N][N];
int match[N],vis[N];
int n,cnt;
int Next[4][2]={1,0,-1,0,0,1,0,-1};
vector<int>G[N]; 
void init(){
	memset(num,0,sizeof(num));
	cnt=0;
	for(int i=0;i<N;i++)
	   G[i].clear();
}
int Find(int u){
	for(int i=0;i<G[u].size();i++){
		int v=G[u][i];
		if(!vis[v]){
			vis[v]=1;
			if(match[v]==-1||Find(match[v])){
				match[v]=u;
				return 1;
			}
		}
	}
	return 0;
}
void Maxmatch(){
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i=1;i<=cnt;i++){
		memset(vis,0,sizeof(vis));
		ans+=Find(i);
	}
	printf("%d\n",ans/2);
}
int main(){
	int T,Cas=0;
	scanf("%d",&T);
	while(T--){
		init();
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%s",mp[i]);
			for(int j=0;j<n;j++){
				if(mp[i][j]=='#'){
					num[i][j]=++cnt;
				}
			}
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				if(mp[i][j]=='#'){
					for(int k=0;k<4;k++){
						int x=i+Next[k][0];
						int y=j+Next[k][1];
						if(x<0||y<0||x>=n||y>=n) continue;
						if(mp[x][y]=='#')
						  G[num[i][j]].push_back(num[x][y]);
					}
				}
			}
		}
		printf("Case %d: ",++Cas);
		Maxmatch();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值