quadratic equation

Problem Description

With given integers a,b,c, you are asked to judge whether the following statement is true: "For any x, if a+bx+c=0, then x is an integer."

Input

The first line contains only one integer T(1≤T≤2000), which indicates the number of test cases.
For each test case, there is only one line containing three integers a,b,c(−5≤a,b,c≤5).

Output

or each test case, output “YES” if the statement is true, or “NO” if not.

Sample Input
3
1 4 4
0 0 1
1 3 1
Sample Output
YES
YES
NO
Hint
Source
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

题意:给你一个逻辑公式,给出a,b,c,让你判断这个逻辑公式对错;

思路:

只要有x在a*x*x+b*x+c==0这个式子成立,那么x一定是整数,即:


p   q    p->q

0   0      1
0   1      1
1   0      0

1   1      1

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		double a,b,c;
		scanf("%lf%lf%lf",&a,&b,&c);
		if(a==0&&b==0){
			if(c==0) printf("NO\n"); //当a=b=c=0时,所有的x都符合,所以是NO 
			else printf("YES\n");//c!=0,前式为0,无论后式为何值,结果都为0 
		}
		else if(a==0){
			if((-c/b)==(int)(-c/b)) printf("YES\n");
			else printf("NO\n");
		}
		else if(b*b-4*a*c>=0){
			int flag=0;
			for(int i=-5;i<=5;i++)
			   if(a*i*i+b*i+c==0) flag++;
			if(b*b-4*a*c==0&&flag==1) printf("YES\n");
			else if(b*b-4*a*c>0&&flag==2) printf("YES\n");
			else printf("NO\n");
		}
		else printf("YES\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值