2018中国大学生程序设计竞赛 - 网络选拔赛 Buy and Resell(贪心)

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

 

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

 

Sample Output

 

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

 

题意:
有n个城市,每个城市交易商品的价格为ai,在任意一个城市可以花ai买入一个商品,或者卖商品赚ai(如果手里有商品),或者不进行任何交易;如何能使获利最大的情况下,交易次数最少,输出最大获利和交易次数。

思路:

能卖出就卖出,卖出的商品可以反悔,即可以在A城市卖出的再买入,相当于在A城市不进行任何交易,我们维护一个最小堆,如果当前价格高于堆顶价格,则在堆顶的城市买入,在当前城市卖出,如果堆顶元素被卖出过,则卖出又买入,相当于在堆顶的城市,没有进行过交易,在该城市还可以进行交易,加入到堆中;

如果当前价格低于堆顶价格,则当前位置不执行卖交易,加入到队列中

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
const int N = 1e5+5;
struct node{
	int x,val; //城市编号,价格 
	bool sell; //是否进行卖交易 
	node(){
	}
	node(int a,int b,bool c){
		x=a;
		val=b;
		sell=c;
	}
	bool operator<(const node other)const{  
		if(val==other.val) return !sell;
		return val>other.val;  //价格小的优先 
	}
};
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		priority_queue<node>p;
		int n;
		scanf("%d",&n);
		int x;
		scanf("%d",&x);
		p.push(node(1,x,false)); 
		
		LL ans=0,time=0;
		for(int i=2;i<=n;i++){
			scanf("%d",&x);
			node temp(0,0,false);
			node top=p.top();
			if(x>top.val){  //如果之前有当前价格低,则当前做卖出交易 
				p.pop();
				ans+=x-top.val;
				if(top.sell){//如果在之前的城市卖出过,现在又买入 
					top.sell=false;//相当于没有交易,两次交易合为一次交易 
					p.push(top);
				}
				else time++;  //反之交易增加 
				temp.sell=true;
			}
			
			temp.x=i; //当前城市入队 
			temp.val=x;
			p.push(temp);
		}
		
		printf("%lld %lld\n",ans,time*2);//一次交易涉及两个城市 
		
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值