Sparse Graph HDU - 5876 (补图的最短路)

In graph theory, the complement of a graph G is a graph H on the same vertices such that two distinct vertices of H are adjacent if and only if they are not adjacent in G.

Now you are given an undirected graph G of N nodes and M bidirectional edges of unit length. Consider the complement of G, i.e., H. For a given vertex S on H, you are required to compute the shortest distances from S to all N−1

other vertices.

Input

There are multiple test cases. The first line of input is an integer T(1≤T<35)

denoting the number of test cases. For each test case, the first line contains two integers N(2≤N≤200000) and M(0≤M≤20000). The following M lines each contains two distinct integers u,v(1≤u,v≤N) denoting an edge. And S (1≤S≤N)

is given on the last line.

Output

For each of T

test cases, print a single line consisting of N−1 space separated integers, denoting shortest distances of the remaining N−1 vertices from S

(if a vertex cannot be reached from S, output ``-1" (without quotes) instead) in ascending order of vertex number.

Sample Input

1
2 0
1

Sample Output

1

题意:给一个无向图以及一个点S,求在其补图点S到其他n+1个点的最短距离。

思路:利用原图求补图上 的最短路,BFS遍历,从u到与u不相连的边的距离可以直接算出

dis[v]=dis[u]+1;然后将这些不邻接的点加入到队列,继续寻找,用两个集合,一个记录不邻接的

点,一个记录没有用过的点

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<set>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 2e5+5;
struct node{
	int v,w;
	int next;
}edge[N*2];
int id,head[N];
int vis[N],dis[N];
void init(){
	id=0;
	memset(head,-1,sizeof(head));
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
}
void add(int u,int v,int w){
	edge[id].v=v;
	edge[id].w=w;
	edge[id].next=head[u];
	head[u]=id++;
}

void BFS(int s,int n){
	set<int>s1; //记录不邻接的点 
	set<int>s2; //记录没有用过的点 
	set<int>::iterator it;
	for(int i=1;i<=n;i++)
		if(i!=s) s1.insert(i);
	queue<int>p;
	p.push(s);
	dis[s]=0;
	while(!p.empty()){
		int u=p.front();
		p.pop();
		for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].v;
			if(!s1.count(v)) continue;
			s1.erase(v);
			s2.insert(v);
		}
		for(it=s1.begin();it!=s1.end();it++){
			p.push(*it);
			dis[*it]=dis[u]+1;
		}
		s1.swap(s2);
		s2.clear();
	}
}

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		init();
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			add(u,v,1);
			add(v,u,1);
		}
		int s;
		scanf("%d",&s);
		BFS(s,n);
		for(int i=1;i<=n;i++){
			if(i==s) continue;
			if(dis[i]==Inf) dis[i]=-1;
			printf("%d",dis[i]);
			if(i==n) printf("\n");
			else printf(" ");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值