HDU 1005测试数据有问题

Problem Description:

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input:
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


Output:

For each test case, print the value of f(n) on a single line.


Sample Input:

1 1 3
1 2 10
0 0 0

Sample Output:
2
5


import java.util.Scanner;

public class Main {
public static void main(String[] args){
int n;
int A,B;
int[] f = new int[4];

Scanner scan = new Scanner(System.in);
A = scan.nextInt();
B = scan.nextInt();
n = scan.nextInt();

while(A != 0 && B != 0 && n != 0){
f[1] = 1;
f[2] = 1;
if(n > 48)
n = n % 48;
for(int i = 3;i <= n;i++){
f[3] = (A * f[2] + B * f[1]) % 7;
f[1] = f[2];
f[2] = f[3];
}
if(n >= 3)
System.out.println(f[3]);
else
System.out.println(1);
A = scan.nextInt();
B = scan.nextInt();
n = scan.nextInt();
}
}
}

f[n]模7的余数在0~6,且与f[n-1]和f[n-1]模7的余数有关。f[n-1]和f[n-2]模7余数的组合不超过49种,由鸽巢原理知,f[n]的模7余数出现的周期不超过49。

上面的代码中,如果没有if(n > 48)那一行,设A=B=1,n = 48时,n = n % 48 = 0,所以输出1,而事实上f[48] = 0。

可提交的结果居然AC!看来测试数据还是有漏洞的。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值