POJ 3505 Tower Parking

Tower Parking
Time Limit:1000MS Memory Limit:65536K

Description

There is a new revolution in the parking lot business: the parking tower. The concept is simple: you drive your car into the elevator at the entrance of the tower, and the elevator and conveyor belts drag the car to an empty parking spot, where the car remains until you pick it up. When you return, the elevator and conveyor belts move your car back to the entrance and you’re done.

The layout of the tower is simple. There is one central elevator that transports the cars between the different floors. On each floor there is one giant circular conveyor belt on which the cars stand. This belt can move in clockwise and counterclockwise direction. When the elevator arrives on a floor, it becomes part of the belt so that cars can move through it.

At the end of the day the tower is usually packed with cars and a lot of people come to pick them up. Customers are processed in a first come first serve order: the elevator is moved to the floor of the first car, the conveyor belt moves the car on the elevator, the elevator is moved down again, and so on. We like to know how long it takes before the last customer gets his car. Moving the elevator one floor up- or downwards takes 10 seconds and moving a conveyor belt one car in either direction takes 5 seconds.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with two integershandlwith 1 ≤h≤ 50 and 2 ≤l≤ 50: the height of the parking tower and the length of the conveyor belts.

  • hlines withlintegers: the initial placement of the cars. Thejth number on theith line describes thejth position on theith floor. This number is −1 if the position is empty, andrif the position is occupied by therth car to pick up. The positive numbers form a consecutive sequence from 1 to the number of cars. The entrance is on the first floor and the elevator (which is initially empty) is in the first position. There is at least one car in the parking tower.

Output

Per testcase:

  • One line with the number of seconds before the last customer is served.

Sample Input

2
1 5
-1 2 1 -1 3
3 6
-1 5 6 -1 -1 3
-1 -1 7 -1 2 9
-1 10 4 1 8 -1

Sample Output

25

320


注意:本来是水题,可是理解错了,那个传送带是每层都有,所以每一层的传送带的距离都不同,层间没有关系,所以需要使用个数组存储,而不是只使用一个临时变量。

冋.....................而不是像下图所示的

由于以前看到过这样的视频,所以主观臆断

下面就是视频地址惊恐








http://www.tudou.com/programs/view/TH--UuxKx_s/

下面是AC代码


/**************************************************************************
* Problem: POJ 3505 Tower Parking
* Copyright 2011 by Yan
* DATE:
* E-Mail: yming0221@gmail.com
************************************************************************/
#include <stdio.h>

typedef struct pos
{
	int x,y;
}pos;
pos position[2501];
int turn[51];/*每一层的指向位置*/

/*n为循环数组的总长度,x和y分别是两个元素的位置[0--n-1]
*求两个元素的最短距离
*/
int min(int n,int x,int y)
{
	return (x-y+n)%n<(y-x+n)%n?(x-y+n)%n:(y-x+n)%n;
}

int main()
{
	int n;
	int h,l,tmp;
	int i,j;
	int cnt;
	int ans;

	int tmp_x,tmp_y;/*用于保存上次的指针位置*/

	/*freopen("input","r",stdin);*/

	scanf("%d",&n);
	while(n--)
	{

		scanf("%d %d",&h,&l);
		cnt=0;
		ans=0;
		/*Input*/
		for(i=0;i<h;i++)
		{
			turn[i]=0;/*每层指针指向0位置*/
			for(j=0;j<l;j++)
			{
				scanf("%d",&tmp);
				if(tmp!=-1)
				{
					position[tmp-1].x=i;
					position[tmp-1].y=j;
					cnt++;
				}
			}
		}
		/*End of Input*/

		for(i=0;i<cnt;i++)
		{
			/*printf("%d %d %d\n",i+1,position[i].x,position[i].y);*/
			ans+=20*position[i].x;
			ans+=5*min(l,position[i].y,turn[position[i].x]);

			turn[position[i].x]=position[i].y;
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值