JOJ ACM 1146

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output
For each test case, print the output on one line.

Sample Input
1

3
I am happy today
To be or not to be
I want to win the practice contest
Sample Output
I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc
code:
[code]
#include<cstdio>

int main()
{
int num,n,size,ts=0,flag;
char c[1000],ch,temp[40];
scanf("%d",&num);
while(num)
{
scanf("%d",&n);
flag = n;
while(n)
{
size=0;
if(flag==n)
getchar();
do{
ch=getchar();
if(ch!=' '&&ch!='\n')
{
temp[ts++]=ch;
}
else if(ch==' '|| ch=='\n')
{
for(int i=ts-1;i>=0;i--)
{
c[size++]=temp[i];
}
if(ch==' ')
{
c[size]=' ';
size++;
}
ts = 0;
}
}while(ch!='\n');

for(int j=0;j<size;j++)
printf("%c",c[j]);
printf("\n");
n--;
}
num--;
if(num>0)
printf("\n");
}
return 0;
}

[/code]
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值