问题如下:
描述 输入三个字符(可以重复)后,按各字符的ASCII码从小到大的顺序输出这三个字符。-
输入
- 第一行输入一个数N,表示有N组测试数据。后面的N行输入多组数据,每组输入数据都是占一行,有三个字符组成,之间无空格。 输出
- 对于每组输入数据,输出一行,字符中间用一个空格分开。 样例输入
-
3 qwe asd zxc
样例输出
-
e q w a d s c x z
代码如下:
import java.util.*;
public class Main
{
public static void main(String[] args)
{
char[] order = new char[3];
Scanner input = new Scanner(System.in);
System.out.println("请输入行数N");
int N = input.nextInt();
String[] st = new String[N];
for(int index = 0; index < N; index++)
{
System.out.println("请输入"+index+"行");
st[index] = input.next();
}
for(int index = 0; index < N; index++)
{
char[] out = new char[3];
out = order(st[index]);
for (int i = 0; i <3; i++)
{
System.out.print(out[i]+" ");
}
System.out.print('\n');
}
}
public static char[] order(String str)
{
char[] ch = str.toCharArray();
Arrays.sort(ch);
return ch;
}
}