poj 2348 Euclid's Game-----博弈

Euclid's Game
Time Limit:1000MS Memory Limit:65536K
Total Submissions:6030 Accepted:2441

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins


题目 没难度, 但是被坑了,int型不够。  所以要 long long 。
题目大意:  每次可以 把两个数中 较大数 减去 较小数的 倍数   ,  两人轮流操作, 先到 0 的赢。

//Memory: 164 KB		Time: 0 MS
//Language: C++		Result: Accepted
#include<stdio.h>
#define LL long long
int main()
{
//	freopen("in.txt","r",stdin);
	LL m,n,t,ok;
	while(~scanf("%lld%lld",&m,&n) && (n||m))
	{
		ok=1;
		if(n>m)t=m,m=n,n=t;
		while(1)
		{
			if(m>=2*n) break;
			m-=n;
			if(n>m)t=m,m=n,n=t;
			if(!n) break;
			ok=(!ok);
		}
		if(ok) printf("Stan wins\n");
		else printf("Ollie wins\n");	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值