SWUST OJ#99 Euclid‘s Game

题目描述

Starts with two unequal positive numbers (M,N and M>N) on the board. Two players move in turn. On each move, a player has to write on the board a positive number equal to the difference of two numbers already on the board; this number must be new, i.e., different from all the numbers already on the board. The player who cannot move loses the game. Should you choose to move first or second in this game?

According to the above rules, there are two players play tihs game. Assumptions A write a number on the board at first, then B write it.

从黑板上两个不等的正数(M,N和M>N)开始。两个玩家依次移动。每走一步棋,玩家必须在棋盘上写下一个正数,等于棋盘上两个数字之差;这个号码必须是新的,也就是说,不同于所有已经在黑板上的号码。不能移动的玩家输掉这场游戏。在这个游戏中,你应该选择先移动还是后移动?

根据上面的规则,有两个玩家在玩这个游戏。假设A先在黑板上写一个数字,然后B再写。

你的任务是写一个程序来判断获胜者是a还是B。


Your task is write a program to judge the winner is A or B.

输入

 
 

Two unequal positive numbers M and N , M>N (M<1000000)

输出

 
 

A or B

样例输入复制

3 1

样例输出复制

A
#include<bits/stdc++.h>
#define ll long long
#define int ll
#define pii pair<int,int>
#define mem(a,b) memset(a,b,sizeof(a))
#define endl '\n'
#define N 100005
const int inf=0x3f3f3f3f;
const double pi=acos(-1.0);
using namespace std;
signed main()
{
	int a,b;
	cin>>a>>b;
	int g=__gcd(a,b);
	a/=g;
	//奇数 
	if(a&1)	cout<<"A"<<endl; 
	else cout<<"B"<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值