Euclid's Game - poj2348 - 博弈论(找规律)

Euclid's Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10660 Accepted: 4340

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

         25 7

         11 7

          4 7

          4 3

          1 3

          1 0


an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

Waterloo local 2002.09.28

题意:Stan和Ollie轮流从较大的数字中减去较小的数字的倍数,(大于0的整数倍),相减后的结果不能小于0,Stan先,先将其中一个数减到0获胜,问谁胜。

思路:

设两个数:a,b(b>a),有两种情况

(1)b-a<a       那么只能减去1倍a。

(2)b-a>a       可以有多种倍数选择。

对于第一种情况,没有选择余地,那么减去后是必胜态,它就是必败态,减去后是必败态,他就是必胜态。

对于第二种情况,假设x,使得b-ax<a,考虑一下从b中减去x-1个a的情况,这时候就只能再减去1倍的a了,成了没选择的(1)情况。

如果该状态是必败的话,当前状态就是必胜状态

(a,b)->(a,b-(x-1)a)先手把必败态留给后手(a,b-(x-1)a)

如果当前状态是必胜的话,那那那……我们就想办法呗~

此时b-ax后的状态是减去a*(x-1)后的专题太唯一可以转移到的状态,(a,b-(x-1)a)必胜,那么(a,b-x*a)必败,作为先手,我们就直接让对方到这个状态就行了:

(a,b)->(a,b-x*a)

所以对于情况(2)来说总是必胜的~

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring> 
#include<queue>
#include<cmath>
using namespace std;

int main(){
	int a,b;
	while(scanf("%d%d",&a,&b)==2&&(a+b)!=0){
		int f=1;
		for(;;){
			if(a>b)swap(a,b);//a<b 
			if(b%a==0)break;
			if(b-a>a)break;
			b-=a;
			f=!f; 
		}
		if(f)printf("Stan wins\n");
		else printf("Ollie wins\n"); 
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值