poj 2230 Watchcow (欧拉回路+dfs)

Watchcow

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Special Judge
Problem Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

 

Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

 

Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

 

Sample Input
 
 
4 5 1 2 1 4 2 3 2 4 3 4

 

Sample Output
 
 
1 2 3 4 2 1 4 3 2 4 1
 
          题目大意:给你一幅连通的图,要求从起点1开始走,要经过每条边刚好两次,并且最终回到1起点。其实就是再每条边基础上加多一条不同方向的边,这样再一个dfs就搞定了,很简单。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;

struct edge
{
    bool vis;
    int end, next;
}a[100005];

int res[100005], adj[100005];    //adj是第一条的编号
int n, m, cnt, ant;

void init()
{
    int i;
    for(i = 0; i <= 2*m; i++)
    {
        a[i].vis = false;
    }
    memset(adj, -1, sizeof(adj));
    ant = cnt = 0;
}

void dfs(int cur, int id)
{
    int i;
	for(i = adj[cur]; i != -1; i = a[i].next)
	{
		if(!a[i].vis)
		{
			a[i].vis = true;
			dfs(a[i].end, i);
		}
	}
	if(id != -1) res[ant++] = a[id].end;
}

int main()
{
    int i, x, y;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        init();
        for(i = 0; i < m; i++)
        {
            scanf("%d %d", &x, &y);
            /// *****建边*****
            a[cnt].end = y;
            a[cnt].next = adj[x];
            adj[x] = cnt++;
            a[cnt].end = x;
            a[cnt].next = adj[y];
            adj[y] = cnt++;
            /// ***************
        }
        dfs(1, -1);
        printf("1\n");
        for(i = ant-1; i >= 0; i--)
        {
            printf("%d\n", res[i]);
        }
    }

    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值