POJ 2230 Watchcow 欧拉回路

http://poj.org/problem?id=2230

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist. 

Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path. 

Output
* Lines 1…2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint
OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc... 

题目大意:寻找从 1 1 1开始经过每条边正反两次最终回到 1 1 1的路径。
思路:欧拉回路模板题。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=1e4+5;
const int maxm=5e4+5;

struct edge
{
    int to,nxt;
}Edge[maxm<<1];

int head[maxn],Stack[maxm<<1],ans[maxm<<1];
bool vis[maxm<<1];
int n,m,tot,top,num;

void addedge(int x,int y)
{
    Edge[++tot].to=y,Edge[tot].nxt=head[x],head[x]=tot;
}

void euler()
{
    top=num=0;
    Stack[++top]=1;
    int x,i;
    while(top>0)//模拟dfs
    {
        x=Stack[top],i=head[x];
        if(i)
        {
            Stack[++top]=Edge[i].to;
            vis[i]=1;
            head[x]=Edge[i].nxt;//删去已经走过的边
        }
        else//x已经访问完毕 回溯过程
        {
            --top;
            ans[++num]=x;
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(head,0,sizeof(head));
        tot=0;
        int x,y;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            addedge(x,y),addedge(y,x);
        }
        euler();
        for(int i=num;i>=1;i--)
            printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值