POJ - 2230 Watchcow(欧拉回路+dfs输出路径)

点击打开题目链接

Watchcow
Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 7926Accepted: 3462Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:首先给出N个点和M条路径,然后对于每条路径正向和负向分别可以走一次,题目声明所给路径可以构成欧拉回路,输出可以从起点开始遍访所有点最终回到起点的路径。

思路:因为并不是所有点之间都存在通路,所以这里用邻接表存图而不用邻接矩阵存图,减少内存空间的使用。然后dfs遍历输出路径即可。(才知道结构体也是可以有构造函数的

附上AC代码:

#include<iostream>
#include<vector>

using namespace std;
const int maxn=10000+5;
int N,M;
int fr,to;

struct edge{
int v;
int vis;
edge(int _v,int _vis):v(_v),vis(_vis){}
};

vector<edge>_map[maxn];

void init()
{
    for(int i=1;i<=N;i++)
        _map[i].clear();
}
void euler_dfs(int cnt)
{
    for(int i=0;i<(int)_map[cnt].size();i++)
    {
        edge &e=_map[cnt][i];
        if(!e.vis)
        {
            e.vis=1;
            euler_dfs(e.v);
        }
    }
    cout<<cnt<<endl;
}
int main()
{
    ios::sync_with_stdio(false);
    cin>>N>>M;
    init();
    for(int i=0;i<M;i++)
    {
        cin>>fr>>to;
        _map[fr].push_back(edge(to,0));
        _map[to].push_back(edge(fr,0));
    }
    euler_dfs(1);
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值