UVA 11039 - Building designing

Building designing

An architect wants to design a very high building. The building will consist of some floors, and each floor has a certain size. The size of a floor must be greater than the size of the floor immediately above it. In addition, the designer (who is a fan of a famous Spanish football team) wants to paint the building in blue and red, each floor a colour, and in such a way that the colours of two consecutive floors are different.

To design the building the architect hasnavailable floors, with their associated sizes and colours. All the available floors are of different sizes. The architect wants to design the highest possible building with these restrictions, using the available floors.

Input

The input file consists of a first line with the numberpof cases to solve. The first line of each case contains the number of available floors. Then, the size and colour of each floor appear in one line. Each floor is represented with an integer between -999999 and 999999. There is no floor with size 0. Negative numbers represent red floors and positive numbers blue floors. The size of the floor is the absolute value of the number. There are not two floors with the same size. The maximum number of floors for a problem is 500000.

Output

For each case the output will consist of a line with the number of floors of the highest building with the mentioned conditions.

Sample Input

 
2
5
7
-2
6
9
-3
8
11
-9
2
5
18
17
-15
4

Sample Output

 
2
5

题意:给定一个序列,要求选出一个子序列排列出一正一负交替并且绝对值递增,求子序列最长长度。

思路:先按绝对值排序,然后一个个去枚举,如果不和之前一个同正或同负就+1.

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int N = 500005;

int t, n, num[N];

bool cmp(int a, int b) {
    return abs(a) < abs(b);
}

void init() {
    scanf("%d", &n);
    for (int i = 0; i < n; i ++)
	scanf("%d", &num[i]);
    sort(num, num + n, cmp);
}

int solve() {
    int ans = 1, flag = 0;
    if (num[0] < 0) flag = 0;
    else flag = 1;
    for (int i = 1; i < n; i ++) {
	if (flag == 0 && num[i] > 0) {
	    flag = 1; ans ++;
	}
	else if (flag == 1 && num[i] < 0) {
	    flag = 0; ans ++;
	}
    }
    return ans;
}

int main () {
    scanf("%d", &t);
    while (t--) {
	init();
	printf("%d\n", solve());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值