Checker Challenge(皇后问题 + DFS)

Checker Challenge

Examine the 6x6 checkerboard below and note that the six checkers are arranged on the board so that one and only one is placed in each row and each column, and there is never more than one in any diagonal. (Diagonals run from southeast to northwest and southwest to northeast and include all diagonals, not just the major two.)

 

          Column
    1   2   3   4   5   6
  -------------------------
1 |   | O |   |   |   |   |
  -------------------------
2 |   |   |   | O |   |   |
  -------------------------
3 |   |   |   |   |   | O |
  -------------------------
4 | O |   |   |   |   |   |
  -------------------------
5 |   |   | O |   |   |   |
  -------------------------
6 |   |   |   |   | O |   |
  -------------------------

The solution shown above is described by the sequence 2 4 6 1 3 5, which gives the column positions of the checkers for each row from 1 to 6:

ROW123456
COLUMN246135

This is one solution to the checker challenge. Write a program that finds all unique solution sequences to the Checker Challenge (with ever growing values of N). Print the solutions using the column notation described above. Print the the first three solutions in numerical order, as if the checker positions form the digits of a large number, and then a line with the total number of solutions.

Special note: the larger values of N require your program to be especially efficient. Do not precalculate the value and print it (or even find a formula for it); that's cheating. Work on your program until it can solve the problem properly. If you insist on cheating, your login to the USACO training pages will be removed and you will be disqualified from all USACO competitions. YOU HAVE BEEN WARNED.

TIME LIMIT: 1 CPU second

PROGRAM NAME: checker

INPUT FORMAT

A single line that contains a single integer N (6 <= N <= 13) that is the dimension of the N x N checkerboard.

SAMPLE INPUT (file checker.in)

6

OUTPUT FORMAT

The first three lines show the first three solutions found, presented as N numbers with a single space between them. The fourth line shows the total number of solutions found.

SAMPLE OUTPUT (file checker.out)

2 4 6 1 3 5
3 6 2 5 1 4
4 1 5 2 6 3
4

 

   题意:

   皇后问题。给出N,表示有一个N行N列的矩阵,要求放N个棋子,任意两个棋子不在同一行同一列同一对角线(无论是正向还是反向)上。

 

   思路:

   可以用DFS,也可以用位运算。DFS标记三个方向(竖,主对角线,反向对角线),对每行搜索。注意主对角线是横纵坐标差绝对值相等,反对角线是和相等。

 

   AC:

/*   
TASK:checker   
LANG:C++   
ID:sum-g1   
*/ 
#include<stdio.h>
#include<string.h>
int n;
int c[15],s[100],bs[100];
int fin[15],ans = 0;

void dfs(int x,int y)
{
    c[y] = 1;
    s[x - y + 15] = 1;   //主对角线差绝对值相等
    bs[x + y] = 1;       //反向对角线和相等
    fin[x] = y;
    if(x == n) ans++;
    if(ans <= 3 && x == n)
    {
        for(int i = 1;i <= n;i++)
        {
            printf("%d",fin[i]);
            i == n ? printf("\n") : printf(" ");
        }
    }
    for(int i = 1;i <= n;i++)
    {
        if(i == y) continue;
        if(!c[i] && !s[x + 1 - i + 15] && !bs[x + 1 + i])
        {
            dfs(x + 1,i);
            c[i] = 0;
            s[x + 1 - i + 15] = 0;
            bs[i + x + 1] = 0;
        }
    }
}

int main()
{
    freopen("checker.in","r",stdin);      
    freopen("checker.out","w",stdout); 
    scanf("%d",&n);
    for(int i = 1;i <= n;i++)
    {
        memset(c,0,sizeof(c));
        memset(s,0,sizeof(s));
        memset(bs,0,sizeof(bs));
        dfs(1,i);
    }
    printf("%d\n",ans);
    return 0;
}

 

   

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值