Babelfish(字典树)

Babelfish
Time Limit: 3000MS  Memory Limit: 65536K
Total Submissions: 29680  Accepted: 12848

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source

    题意:

    给出一系列单词和译文,空行后开始询问译文,每个询问输出一个答案,如果译文能输出对应的单词,则输出这个单词,不能则输出 eh。

   

    思路:

    字典树。将对应单词输入到译文最后一个字母中,每次询问则查找字典树即可。

 

    AC:

#include<cstdio>
#include<string.h>
using namespace std;

typedef struct no
{
    struct no *next[30];
    char sen[15];
}node;

node *creat_node()
{
    node *p = new node;
    for(int i = 0;i < 30;i++)
        p -> next[i] = NULL;
    memset(p -> sen,0,sizeof(p -> sen));
    return p;
}

void insert_str(char *str,char *vab,node *head)
{
    int len = strlen(str);
    node *p = head;
    for(int i = 0;i < len;i++)
    {
        int c = str[i] - 'a';
        if(p -> next[c] == NULL)    
           p -> next[c] = creat_node();
        p = p -> next[c];
    }
    strcpy(p -> sen,vab);
}

void search_str(char *str,node *head)
{
    int len = strlen(str),i;
    node *p = head;
    for(i = 0;i < len;i++)
    {
        int c = str[i] - 'a';
        if(p -> next[c] == NULL) break;
        p = p -> next[c];
    }
//除了判断i < len以外,还要判断长度,因为当这个译文为某字典译文的前缀时,最后一个字母没有存到单词信息
    if(i < len || !strlen(p -> sen)) printf("eh\n");
    else                             printf("%s\n",p -> sen);
}

int main()
{
    char str[3005],vab[30],tra[30];
    node *head = creat_node();

    while(gets(str) && strlen(str))
    {
        int temp = 0,k = 0;
        memset(vab,0,sizeof(vab));
        memset(tra,0,sizeof(tra));
        for(int i = 0;i < strlen(str);i++)
        {
            if(str[i] == ' ')
            {
                temp = 1;
                vab[k] = '\0';
                k = 0;
                continue;
            }
            if(!temp)   vab[k++] = str[i];
            else        tra[k++] = str[i];
        }
        tra[k] = '\0';
        insert_str(tra,vab,head);
    }

    while(gets(str))
    {
        search_str(str,head);
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值