PAT1011 World Cup Betting

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98

 

#include <iostream>
#include <iomanip>
#include <string>
using namespace std;

int main()
{
	int N = 3;
	float total = 1;
	string str;
	while (N--)
	{
		float x,y,z;
		cin>>x>>y>>z;
		float Max = max(max(x,y),z);
		if (Max == x)
		{
			str += "W ";
		}
		else if (Max == y)
		{
			str += "T ";
		}
		else
		{
			str += "L ";
		}
		total *= Max;
	}
	cout.setf(ios::fixed);
	float Result = (total * 0.65 - 1)*2;
	cout<<str<<setprecision(2)<<Result;
	return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值