小红伞(antivir)+xp sp3与rake rails:freeze 有冲突?

今天想把rails升到2.1,便想把以前的项目固化一下版本,但却总是出现permission denied错误。在网上找了一会,看到有的人说是gems版本的原因,有的说是rails文件被破坏了。我便把ruby和rails都卸了重装,问题依旧。又怀疑是文件夹权限问题,就把文件夹的权限全部放开,还是不行。后来实在没办法,就怀疑到了杀毒软件头上。我机器上装的是windows xp sp3 + 微点 + 小红伞C版,先把微点禁了,没用。将微点开启,再把antivir禁用,居然就好了。随后我又重复做了多次试验,确认就是antivir引起的问题,但奇怪的是它没有任何警报或是日志记录,更奇怪的是在我另一台装vista的机器上,同样是 微点 + 小红伞C版,就根本没这个问题。真是郁闷。

另外请教下,为什么我在xp上执行rake rails:freeze:gems会出来以下详细信息
Freezing to the gems for Rails 2.1.0
rm -rf vendor/rails
mkdir -p vendor/rails
cd vendor/rails
Unpacked gem: 'D:/download/soft/test/vendor/rails/activesupport-2.1.0'
mv activesupport-2.1.0 activesupport
而在vista中就没有这么详细?两台机器的所有gems都已经是最新版了。
阅读更多

没有更多推荐了,返回首页