#HDU4372#Count the Buildings(第一类Stirling数经典)

27 篇文章 0 订阅
14 篇文章 0 订阅

Count the Buildings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1512    Accepted Submission(s): 508

Problem Description
There are N buildings standing in a straight line in the City, numbered from 1 to N. The heights of all the buildings are distinct and between 1 and N. You can see F buildings when you standing in front of the first building and looking forward, and B buildings when you are behind the last building and looking backward. A building can be seen if the building is higher than any building between you and it.
Now, given N, F, B, your task is to figure out how many ways all the buildings can be.

Input
First line of the input is a single integer T (T<=100000), indicating there are T test cases followed.
Next T lines, each line consists of three integer N, F, B, (0<N, F, B<=2000) described above.

Output
For each case, you should output the number of ways mod 1000000007(1e9+7).

Sample Input
  
  
2 3 2 2 3 2 1
 
Sample Output
  
  
2 1

这题是我参考一篇博文做的,很经典的思考方式,写得也很详细:http://blog.csdn.net/acdreamers/article/details/9732431

建议先看以下,对第一类stirling数的解释,更容易理解。

第一类Stirling:将n个不同的数分成k个非空循环排列一共有多少种方法。

分析:

考虑第n个数,n可以单独构成一个非空循环排列,这样前n-1种数构成k-1个非空循环排列,方法数为s1(n-1,k-1);

也可以前n-1种数构成k个非空循环排列,而第n个数插入第i个数的左边,这有(n-1)*s1(n-1,k)种方法。

S1(n,k)=S1(n-1,k-1)+(n-1)*S1(n-1,k)


Code:

Status Accepted
Time 171ms
Memory 47880kB
Length 663
Lang G++
Submitted
Shared
RemoteRunId 21024287

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

typedef long long LL;

const int MOD = 1e9 + 7;

LL C[2005][2005], S1[2005][2005];

void pre_work(){
	C[0][0] = 1;
	for(int i = 1; i <= 2000; ++ i){
		C[i][0] = C[i][i] = 1;
		S1[i][0] = 0, S1[i][i] = 1;
		for(int j = 1; j < i; ++ j)
			C[i][j] = (C[i - 1][j] + C[i - 1][j - 1]) % MOD,
			S1[i][j] = (S1[i - 1][j - 1] + (i - 1) * S1[i - 1][j]) % MOD;
	}
}

int main(){
	pre_work();
	int T, N, b, f;
	scanf("%d", &T);
	while(T --){
		scanf("%d%d%d", &N, &f, &b);
		if(f + b - 2 > 2000)	puts("0");
		else printf("%I64d\n", C[f + b - 2][f - 1] * S1[N - 1][b + f - 2] % MOD);
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值