Magic Coupon

The magic shop in Mars is offering some magic coupons.  Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back!  What is more, the shop also offers some bonus product for free.  However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product.  You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back.  On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once.  Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case.  For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers.  Then the next line contains the number of products NP, followed by a line with NP product values.  Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

思路:读入coupon和product数组后,先对它们进行排序,按照相同的顺序,比如从小到大。然后分别从首尾两个方向扫描数组,进行累加。从头向尾扫描时,必须要求coupon和product数组中对应元素都为负数才将它们的乘积累加到sum,否则停止扫描;从尾向头扫描时,要求coupon和product数组中对应元素都为正数才将它们的乘积累加到sum,否则停止扫描。

注意:当读到文件末尾(EOF)时,while循环就必须停止。hdu 3794与此类似,需要进一步判断读取到的NC非负。

下面是算法的代码,在PAT上测试通过。

// Magic Coupon - PAT 1037
// by btwsmile
#include<iostream>
#include<algorithm>
using namespace std;

int coupon[1000000];
int product[1000000];

int main()
{
	int coupon_cnt, product_cnt;
	bool bFirstCase = true;
	while(cin>>coupon_cnt && coupon_cnt > 0) {
		for(int i = 0; i < coupon_cnt; ++i)
			cin>>coupon[i];
		cin>>product_cnt;
		for(int i = 0; i < product_cnt; ++i)
			cin>>product[i];
		// sort array
		sort(coupon, coupon + coupon_cnt);
		sort(product, product + product_cnt);
		// calculate
		int sum = 0;
		int steps = (coupon_cnt < product_cnt) ? coupon_cnt : product_cnt;
		// backward
		for(int i = 0; i < steps; ++i) {
			if(coupon[i] >= 0 || product[i] >= 0)
				break; // stop for loop
			sum += coupon[i] * product[i];
		}
		// forward
		for(int i = 0; i < steps; ++i) {
			if(coupon[coupon_cnt - 1 - i] <= 0 ||
				product[product_cnt - 1 -i] <= 0)
				break; // stop for loop
			sum += coupon[coupon_cnt - 1 - i] * product[product_cnt - 1 - i];
		}
		// output
		if(!bFirstCase) cout<<"\n";
		cout<<sum;
		if(bFirstCase) bFirstCase = false;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值