POJ 1417 True Liars(种类并查集+dp+路径输出)

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell. 

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie. 

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia. 

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries. 

Input

The input consists of multiple data sets, each in the following format : 

n p1 p2 
xl yl a1 
x2 y2 a2 
... 
xi yi ai 
... 
xn yn an 

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once. 

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

写了一天,贡献了5发wa终于a了,还是我太菜惹(⋟﹏⋞)

思路:先是并查集分种类,用dp确定路径是否唯一,唯一则输出路径。    

原本dp时打算只开成[2][N]大小来回调用,样例、网上各种数据都过了还是一直wa,终于给我发现了bug决定放弃这个方法。。

思路并不复杂,难的是实现

1 dp要使用的数据如何整合  开一个一维数组,当作连接根节点与data的纽带

2 如何输出路径  路径输出这个网上有好多版本看不懂,自己又捣鼓了半天给弄了出来,应该还是比较简短的。

详见代码


代码:

#include <stdio.h>
#include<string.h>
#define N 605
//f存储父节点 group存储关系 data存储dp使用的数据 div是 森林? 与 data 之间的纽带 path存储路径 ans是逆推的纽带
int f[N],group[N],dp[N][N],path[N][N],data[N][2],div[N],ans[N];

void init(int n){
    int i;
    for(i=1;i<=n;i++)f[i]=i,group[i]=0;
}

int getf(int a){
    if(a==f[a])return a;
    int t=getf(f[a]);
    group[a]=(group[a]+group[f[a]])%2;
    return f[a]=t;
}

void merge(int a,int b,int kin){
    int fa=getf(a),fb=getf(b);
    if(fa==fb)return;
    f[fb]=fa;
    group[fb]=(group[a]+group[b]+kin)%2;
}

int main(){
    int i,j,k,n,p1,p2,a,b,index;
    char s[10];
    while(scanf("%d%d%d",&n,&p1,&p2),n+p1+p2){
        init(p1+p2);//初始化
        for(i=0;i<n;i++){
            scanf("%d%d%s",&a,&b,s);
            if(s[0]=='y')merge(a,b,0);
            else merge(a,b,1);
        }
//以上为种类并查集
        
//按照种类团体进行数据存储,div存储每一个根节点对应的data的行
        memset(data,0,sizeof(data));
        memset(div,0,sizeof(div));
        index=1;
        for(i=1;i<=p1+p2;i++){
            getf(i);//压缩路径使i直连根节点,group也是与根节点关系
            if(!div[f[i]])div[f[i]]=index++;
            data[div[f[i]]][group[i]]++;
        }
        
//寻找能否确定p1是由哪些种类构成
        memset(dp,0,sizeof(dp));
        memset(path,0,sizeof(path));
        dp[0][0]=1;
        for(i=1;i<index;i++){
            for(j=0;j<=p1;j++){
                for(k=0;k<2;k++){
                    if(j-data[i][k]>=0&&dp[i-1][j-data[i][k]]){ //前一半判断是防止越界,后一半是确保前面的选择成立
                            
                        dp[i][j]+=dp[i-1][j-data[i][k]];  //可以使dp的结果存的是到每点有多少种选法
                        
//path的确有重复调用可能,但是能到[index-1][p1]的选择只有一种才能成立,所以该路径上每一点是不会被重复赋值
                        path[i][j]=k;//存储选择了哪一边
                    }
                }
            }
        }

        if(dp[i-1][p1]!=1){//如果能选择的方式不是一种就不能推断
            printf("no\n");
            continue;
        }
//ans存储选了data的0还是1
        a=p1;
        for(i=index-1;i>0;i--){
            ans[i]=path[i][a];
            a-=data[i][ans[i]];
        }
//路径输出
        for(i=1;i<=p1+p2;i++){
            if(group[i]==ans[div[f[i]]])//如果i 是 被选择的那一方,div是连接data与f[i]的纽带,ans是存储data哪边被选
                printf("%d\n",i);
        }
        printf("end\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给出一个$n\times m$的矩阵,每个位置上有一个非负整数,代表这个位置的海拔高度。一开始时,有一个人站在其中一个位置上。这个人可以向上、下、左、右四个方向移动,但是只能移动到海拔高度比当前位置低或者相等的位置上。一次移动只能移动一个单位长度。定义一个位置为“山顶”,当且仅当从这个位置开始移动,可以一直走到海拔高度比它低的位置上。请问,这个矩阵中最多有多少个“山顶”? 输入格式 第一行两个整数,分别表示$n$和$m$。 接下来$n$行,每行$m$个整数,表示整个矩阵。 输出格式 输出一个整数,表示最多有多少个“山顶”。 样例输入 4 4 3 2 1 4 2 3 4 3 5 6 7 8 4 5 6 7 样例输出 5 算法1 (递归dp) $O(nm)$ 对于这道题,我们可以使用递归DP来解决,用$f(i,j)$表示以$(i,j)$为起点的路径最大长度,那么最后的答案就是所有$f(i,j)$中的最大值。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码 算法2 (动态规划) $O(nm)$ 动态规划的思路与递归DP类似,只不过转移方程和实现方式有所不同。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值