并查集+dp True Liars

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell. 

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie. 

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia. 

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries. 

Input

The input consists of multiple data sets, each in the following format : 

n p1 p2 
xl yl a1 
x2 y2 a2 
... 
xi yi ai 
... 
xn yn an 

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once. 

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included. 

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

说no的必定是不同阵营的,说yes的必定是同一阵营的,我们把已经确定是同一阵营的归到一起,最后看那些不同的集合能不能拼成我们所需要的。如果用并查集来做,我们需要加一个记录长度的数组。普通并查集无法完成排除数据相反的点并成一个的情况,可以把每个点的根节点设为0或1,表示与上一段是不是同类,每一段构造出一个数组,然后记录数组的个数和所包含的值,然后利用背包的思路构建dp[i][j]找出dp[n][p1];看其是否为1,是1的话就通过储存在b中的那些数输出结果,不是就不输出。

#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<bitset>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn=600+10;

int f[maxn];
int rank1[maxn];
int a[maxn][2];
vector <int> b[maxn][2];
int dp[maxn][maxn/2];
bool visit[maxn];
int last[maxn][maxn/2];

int find(int x)
{
	if(f[x]==-1)	return x;
	int tmp=find(f[x]);
	rank1[x]+=rank1[f[x]];
	rank1[x]%=2;
	return f[x]=tmp;
}

int main()
{
	int n,p1,p2;
	int i,j,k;
	while(scanf("%d%d%d",&n,&p1,&p2)&&(n||p1||p2))
	{
		//注意做完之后检查有0的情况是否符合
		memset(f,-1,sizeof(f));
		memset(rank1,0,sizeof(rank1));
		for(i=0;i<n;i++)
		{
			int x,y;
			char a[3];
			scanf("%d%d%s",&x,&y,&a);
			int temp;
			if(!strcmp(a,"yes"))
			{
				temp=0;
			}
			else if(!strcmp(a,"no"))
			{
				temp=1;
			}
			int x1=find(x),y1=find(y);
			if(x1!=y1)
			{
				f[x1]=y1;
				rank1[x1]=(rank1[x]-rank1[y]+2+temp)%2;		//这边为什么要用rank1[x],rank1[y];
			}
		}
		for(i=0;i<maxn;i++)
		{
			b[i][0].clear();
			b[i][1].clear();
			a[i][0]=0;
			a[i][1]=0;
		}
		memset(visit,false,sizeof(visit));
		int an=1;
		for(i=1;i<=p1+p2;i++)
		{
			if(!visit[i])
			{
				int pan=find(i);
				for(j=i;j<=p1+p2;j++)
				{
					if(pan==find(j))
					{
						visit[j]=true;
						b[an][rank1[j]].push_back(j);
						a[an][rank1[j]]++;
					}
				}
				an++;
			}
		}
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		for(i=1;i<an;i++)
			for(j=p1;j>=0;j--)
			{
				if(j>=a[i][0]&&dp[i-1][j-a[i][0]])
				{
					dp[i][j]+=dp[i-1][j-a[i][0]];
					last[i][j]=j-a[i][0];				//last表示上一个是什么
				}
				if(j>=a[i][1]&&dp[i-1][j-a[i][1]])
				{
					dp[i][j]+=dp[i-1][j-a[i][1]];
					last[i][j]=j-a[i][1];
				}
			}
		if(dp[an-1][p1]!=1)
			printf("no\n");
		else
		{
			vector <int> ans;
			ans.clear();
			int t=p1;
			for(i=an-1;i>=1;i--)
			{
				int tmp=t-last[i][t];
				if(tmp==a[i][0])
				{
					for(j=0;j<a[i][0];j++)
						ans.push_back(b[i][0][j]);
				}
				else if(tmp==a[i][1])
				{
					for(j=0;j<a[i][1];j++)
						ans.push_back(b[i][1][j]);
				}
				t=last[i][t];
			}
		sort(ans.begin(),ans.end());
		for(i=0;i<ans.size();i++)
			printf("%d\n",ans[i]);
		printf("end\n");
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值