【学习笔记】〖PAT〗1003. Emergency (25)

1003. Emergency (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

这题整了一下午,中间有很多错误值得以后注意。


首先的想法是利用FLOYD找最短路径个数,然后用DFS计算最大救援队数量,后来发现一个DFS可以直接解决


思路,DFS函数传递引用参数来记录已经找到的最短路径和当前最多救援队数目,然后递归调用DFS


函数定义如下


//参数:起始位置,终点,已知最短路径,当前路径长度,当前救援队数量,最大数量


void dfs(int start, int end, int cnum,  int &minLen, int curLen, int res, int &maxRes);


当start == end 时,即到达终点,此时比较路径长度和救援队数量


(犯错1,找到更短路径后,不论当前最大救援队数量是多少,都应该更新res)


如果长度较短,则更新长度minLen和救援队数量maxRes;如果长度相同,则增加路径个数,更新maxRes


在DFS过程中如果当前长度curLen大于已知最短路径可以直接进行剪枝.


(犯错2,在调用DFS时,因为在函数体内对已访问标记mark[i]进行修改,忽略了返回时还原mark状态,导致遍历不全)



#include<cstdio>

using namespace std;

#define M 510

int path[M][M];
int team[M];

int mark[M];
int minCount;

//参数:起始位置,终点,已知最短路径,当前路径长度,当前救援队数量,最大数量
void dfs(int start, int end, int cnum,  int &minLen, int curLen, int res, int &maxRes)
{
	if (start == end)//到达
	{
		if (minLen == -1 || curLen < minLen)
		{
			minLen = curLen;//记录最短路径
			minCount = 1;//计数

			//更改最短路径时,救援队数量改变!!!
			maxRes = res;
		}
		else if (curLen == minLen)
		{
			minCount++;//相同长度
			if (res > maxRes)
			{
				maxRes = res;
			}
		}
		return;
	}

	//未到终点,继续找下一个点
	mark[start] = 1;
	for (int i=0; i<cnum; i++)
	{
		if (mark[i] == 1)//已经走过,跳过
		{
			continue;
		}
		if (path[start][i] == -1)//无路径,跳过
		{
			continue;
		}
		else
		{
			//长度超过最短,跳过
			if (minLen != -1 && curLen+path[start][i] > minLen)
			{
				continue;
			}
			
			//增加队伍,增加长度,继续走
			dfs(i,end,cnum,minLen, curLen+path[start][i], res+team[i], maxRes);
			mark[i] = 0;
		}
	}//end of for
}

int main()
{
	freopen("input.in", "r", stdin);
	freopen("output.out","w", stdout);

	int cnum, rnum, c1,c2, i, j;
	scanf("%d%d%d%d", &cnum, &rnum, &c1, &c2);

	//初始化
	for (i=0; i<cnum; i++)
	{
		for (j=0; j<cnum; j++)
		{
			path[i][j] = -1;
		}
	}

	//输入
	for (i=0; i<cnum; i++)
	{
		scanf("%d", &team[i]);
	}
	while (rnum--)
	{
		int tmp1, tmp2, len;
		scanf("%d%d%d", &tmp1, &tmp2, &len);
		if (path[tmp1][tmp2] == -1 || len<path[tmp1][tmp2])
		{
			path[tmp1][tmp2] = path[tmp2][tmp1] = len;
		}
	}

	//计算救援队
	int res = team[c1];
	int maxRes = team[c1];
	int minLen = -1;//最短路径长度
	minCount = 1;
	for (i=0; i<cnum; i++)
	{
		mark[i] = 0;
	}
	dfs(c1, c2, cnum, minLen, 0, res, maxRes);
	printf("%d %d\n", minCount, maxRes);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值