POJ - 2828 - Buy Tickets(线段树-单点更新找位置)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 16339 Accepted: 8142

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



从后往前找,假设这个人要站在n后面,那他前面n个一定是空位,若不是,则需要保持前面加起来必须有n个空位


#include <string.h>
#include <math.h>
#include <queue>
#include <stack>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
const int M = 200005;
using namespace std;

int a[M];
int b[M];
int c[M];
int sum[M<<2];

void pushup(int rt) {
   sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void build(int l, int r, int rt) {
   if(l == r) {
      sum[rt] = 1;///结点存该位置还有多少个空位
      return;
   }
   int m = (l + r) >> 1;
   build(lson);
   build(rson);
   pushup(rt);
}

///很好(ku)玩(xia)的一个查询,从后往前找,假设这个人要站在n后面,那按道理来说他前面n个都应该是空位置,这样他才算站到了n的后面,但是后面来的人会有插队的情况,而我们又是从后往前找,也就是说把插队的人站的位置排除后有n个位置,那么就是需要保持他前面空位加起来有n个

void query(int a, int b, int l, int r, int rt) {
   if(l == r) {
      sum[rt]--;
      c[l] = b;
      return;
   }
   int m = (l + r) >> 1;
   if(sum[rt<<1] > a)///左结点的空位大于他要站的位置才能进去,不然就表示前面的空位不足,则只能进入右结点
      query(a, b, lson);
   else {
      a -= sum[rt<<1];///进入右结点后则需减去左结点处的空位再往下比较
      query(a, b, rson);
   }
   pushup(rt);
}

int main()
{
   int n;
   while(scanf("%d", &n) != EOF) {
      memset(sum, 0, sizeof(sum));
      memset(c, 0, sizeof(c));
      build(1, n, 1);
      for(int i = 1; i <= n; i++)
         scanf("%d%d", &a[i], &b[i]);
      for(int i = n; i > 0; i--) {
         query(a[i], b[i], 1, n, 1);///从后往前找
      }
      for(int i = 1; i < n; i++)
         printf("%d ", c[i]);
      printf("%d\n", c[n]);
   }
   return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、 4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值