POJ - 3009 - Curling 2.0(dfs)

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17681 Accepted: 7268

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

题意:一个冰壶在冰上运动,1表示冰墙,撞到以后冰墙会破裂变成平地;0表示平地冰壶可以自由运动。冰壶出发后会朝某一个方向一直移动,直到撞到冰墙才会停下来。现在冰壶从2出发到3终止,问最少需要击打冰壶多少次?注:虽然冰壶会把冰墙撞破,但如果冰墙与冰壶紧挨,则不能撞破。

终于下决心学搜索,一个搜索渣渣做题做的快哭粗来QAQ   一道dfs水题,不过搜一横排一竖排感觉略爽,原来还可以这样


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <assert.h>
#define INF 0x3f3f3f3f
using namespace std;


int maps[105][105];
int m, n;
int stx, sty; //记录冰壶初始位置
int ans;
int dir[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};  //4个方向

bool judge(int x, int y)
{
  if(x >= n || y >= m || x < 0 || y < 0)
    return false;
  return true;
}

void dfs(int xx, int yy, int step)
{
  int x, y;
  if (step > 10) return; //嘛,剪枝吧

  for (int i = 0; i < 4; i++) {
    x = xx;
    y = yy; //想了想这两行也很重要,4个方向的初始位置相同,最开始没写,-1了半天不知道为毛= =
    x += dir[i][0];
    y += dir[i][1];
    if (!judge(x, y)) continue;
    if (maps[x][y] == 1) continue;

    while(maps[x][y] != 1 && maps[x][y] != 3) {
      x += dir[i][0];
      y += dir[i][1];
      if(!judge(x, y)) break;
    }
    if(!judge(x, y)) continue; //认为这句代码还是至关重要,标注一下

    if(maps[x][y] == 3) {
      ans = min(ans, step + 1);
    }

    if(maps[x][y] == 1) {
      maps[x][y] = 0;
      dfs(x - dir[i][0], y - dir[i][1], step + 1);
      maps[x][y] = 1;
    }
  }
}

int main()
{
  while(cin >> m >> n) {
    if(!m && !n) break;
    ans = INF; //赋初值无限大
    for (int i = 0; i < n; i++) {
      for (int j = 0; j < m; j++) {
        scanf("%d", &maps[i][j]);
        if (maps[i][j] == 2) {
          stx = i;
          sty = j;
        }
      }
    }
    dfs(stx, sty, 0);
    if(ans > 10) printf("-1\n");
    else printf("%d\n", ans);
  }
  return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值