HDU - 2222 - Keywords Search(AC自动机)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 52282    Accepted Submission(s): 16911


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

题意:给几个模式串,再给一个文章,问出现的模式串的数量,每个模式串只统计一次。

裸的AC自动机,感觉壕讲课还是恢常好的。嗯,比如他能耐心地解决我问的各种zz问题。。

第一次写AC自动机还是写个博客比较好,万一以后又不知道把模板丢哪了2333

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <iostream>
#include <assert.h>
#define INF 0x3f3f3f3f
using namespace std;
const int M = 55;
const int SIZE = 30;
const int N = 5e5 + 10;

char str[M];
int tricnt; //统计结点数
int ch[N][SIZE]; //存结点
int fails[N];
int ed[N];  //以该点结尾的模式串有多少个
bool vis[N]; //当前模式串有没有访问过
char txt[N + N]; //输入文本

int newnode() //建立结点
{
  memset(ch[tricnt], 0, sizeof(ch[tricnt]));
  fails[tricnt] = 0;
  ed[tricnt] = 0;
  vis[tricnt] = false;
  return tricnt++;
}

void init() //初始化
{
  tricnt = 0;
  newnode();
}

void trinsert(char* s) //建字典树,存模式串
{
  int u = 0;
  int len = strlen(s);
  int v;
  for (int i = 0; i < len; i++) {
    v = s[i] - 'a';
    if (!ch[u][v])
      ch[u][v] = newnode();
    u = ch[u][v];
  }
  ed[u]++;
}

void getfail() //构建fail数组,搜索构建
{
  queue<int> q;
  for (int i = 0; i < 26; i++)
    if (ch[0][i])
      q.push(ch[0][i]);

  while (!q.empty()) {
    int r = q.front();
    q.pop();
    for (int i = 0; i < 26; i++) {
      int v = ch[r][i];
      if (v) {
        q.push(v);
        int u = fails[r];
        while (u && !ch[u][i]) //找他的fail值,直到找到或回到根节点为止
          u = fails[u];
        fails[v] = ch[u][i];
      }
    }
  }
}

int finds(char* s)
{
  getfail();
  int tot = 0;
  int u = 0;
  int p, v;
  for (int i = 0; s[i]; i++) {
    v = s[i] - 'a';
    while (u && !ch[u][v]) u = fails[u];
    u = ch[u][v];
    p = u;
    while (p && !vis[p]) {
      tot += ed[p];
      vis[p] = true;
      p = fails[p];
    }
  }
  return tot;
}

int main()
{
  int cascnt;
  cin >> cascnt;
  while (cascnt--) {
    int n;
    scanf("%d", &n);
    init();
    for (int i = 0; i < n; i++) {
      scanf("%s", str);
      trinsert(str);
    }
    scanf("%s", txt);
    printf("%d\n", finds(txt));
  }
  return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值