POJ-2560 Freckles

18 篇文章 0 订阅
8 篇文章 0 订阅
Freckles
Time Limit: 1000MS Memory Limit: 65536K
   

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

Source

Waterloo local 2000.09.23

————————————————————淡疼的分割线————————————————————

思路:原来Kruskal算法就是指以边为对象,先排个序,然后并查集一下就好了……参见 还是畅通工程

要注意的是,Kruskal算法适用于稀疏图而不适用于稠密图,这一点我还不太明白,等我学了Prim算法再说吧?

首先读点,在读点的过程中,将点对点的距离算一下存起来。n个结点能连成n*(n-1)/2条边。排个序,并查集。

代码如下:

/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
const int N = 105;
double ans;
int fa[N];
struct Node
{
	double x, y;
}a[N];
struct Route
{
	double dist;
	int u, v;
}G[N*(N-1)/2];

bool cmp(Route a, Route b)
{
	return a.dist < b.dist;
}

int Find(int x)
{
	if(x != fa[x]) {
		fa[x] = Find(fa[x]);
	}
	return fa[x];
}

void Union(int x, int y, double dist)
{
	int fx = Find(x), fy = Find(y);
	if(fx != fy) {
		ans += dist;
		fa[fy] = fx;
	}
}

int main()
{
	int n, t = 0;
	while(~scanf("%d", &n)) {
		for(int i = 0; i < n; i++) {
			scanf("%lf%lf", &a[i].x, &a[i].y);
			for(int j = 0; j < i; j++) {
				G[t].u = i;
				G[t].v = j;
				G[t++].dist = sqrt((a[j].y - a[i].y)*(a[j].y - a[i].y) + (a[j].x - a[i].x)*(a[j].x - a[i].x));
			}
		}
		sort(G, G+t, cmp);
		ans = 0;
		for(int i = 0; i < n; i++)
			fa[i] = i;
		for(int i = 0; i < t; i++)
			Union(G[i].u, G[i].v, G[i].dist);
		printf("%.2f\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值