UVA 10010 - Where's Waldorf? 题解

Time limit: 3.000 seconds
  Where's Waldorf? 

Given a  m  by  n  grid of letters, (  $1 \leq m,n \leq 20$ ), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n$1 \leqm,n \leq 50$ in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8


题意,在给你的表中找到于所给单词匹配的单词的首字母的位置。可以往8方向匹配。

因为输出没十分理解, 在两个输出块之间需要一个空行,导致wronganswer多次

#include <iostream>
#include <cstdio>
#include <memory.h>
#include <cmath>
#include <cstdlib>
using namespace std;
#define MAXN 50 + 10

char str[MAXN];
char maze[MAXN][MAXN];
int m,n;
const int mx[] = {+0,-1,-1,-1,+0,+1,+1,+1};
const int my[] = {-1,-1,+0,+1,+1,+1,+0,-1};


bool match(char A,char B){
    int m = A - B;
	if (m == 0 || abs((double)m) == 'a' - 'A')
		return true;
	return false;
}

void mv(int& x,int& y,int i){
	x += mx[i];
	y += my[i];
//	if (x < 0)
//		x += m;
//	if (y < 0)
//		y += n;
//	if (x >= m)
//		x -= m;
//	if (y >= n)
//		y -= n;
}

bool getmatched(int x,int y){
    int l = strlen(str);
	for(int i = 0;i < 8;i++){
		int tempx = x,tempy = y;
		for(int j = 0;j < l;j++){
			if (tempx >= 0 && tempx < m && tempy >= 0 && tempy < n){
				if (match(str[j],maze[tempx][tempy])){
					mv(tempx,tempy,i);
					if (j == l - 1)
						return true;
				}
				else
					break;
			}
			else
				break;
		}
	}
	return false;
}



int main(){
    //freopen("in.txt","r",stdin);
	int T;
	int cs = 0;
	for(scanf("%d",&T);T;T--){
	    if (cs)
	    printf("\n");
		scanf("%d%d",&m,&n);
		for(int i = 0;i < m;i++){
			scanf("%s",maze[i]);
		}
		int t;
		for(scanf("%d",&t);t;t--){
			int flag = 0;
			scanf("%s",str);
			for(int i = 0;i < m && !flag;i++){
				for(int j = 0;j < n && !flag;j++){
					if (match(maze[i][j],str[0])){
						if (getmatched(i,j)){
							flag = 1;
							cout<<i+1<<" "<<j+1<<endl;
						}
					}
				}
			}
		}
		//output a blank line
		if (cs == 0) cs = 1;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值