题目描述
输入一个高度h,输出一个高为h,上底边为h的梯形。
输入
一个整数h(1<=h<=1000)。
输出
h所对应的梯形。
样例输入
5
样例输出
代码如下
#include<cstdio>
#include<cstdlib>
int main()
{
int h,i,j,temp;
while(scanf("%d",&h)==1){
temp = (h-1)*2;//记下第一行的空格数
for(i = 0;i < h; i++){
for(j = 0;j < temp; j++){
printf(" ");//打印空格
}
for(j = temp;j < h+(h-1)*2; j++){
printf("*");//接着打印字符*
}
temp-=2;//下一行的空格数减2
printf("\n");
}
}
system("pause");
return 0;
}