Poj2229-Sumsets-【递推】

传送门:http://poj.org/problem?id=2229


Sumsets
Time Limit: 2000MS
Memory Limit: 200000K
Total Submissions: 20086
Accepted: 7849

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver


递推时不要一个劲的往前找,,

题意:给一个数问 有多少种由2的倍数相加组成   如4 : 1+1+1+1  1+1+2  2+2  4   共4种

解题:找递推

奇数

很显然奇数和前一个偶数相同   由前一个偶数在前面+1所得

如7

1+1+1+1+1+1+1
1+1+1+1+1+2
1+1+1+2+2
1+1+1+4
1+2+2+2
1+2+4

偶数   可以由前面2个1(1不可能单数存在)或没有1   

(1):两个1  就是个前一个奇数  即上上一个偶数一样

(2):没有1  就是和这个数除2  的数一样

如8

(1)+1+1+1+1+1+1+1   =2+2+2+2
(1)+1+1+1+1+1+2     =2+2+4
(1)+1+1+1+2+2       =4+4
(1)+1+1+1+4         =8
(1)+1+2+2+2
(1)+1+2+4
2+2+2+2    ==1+1+1+1
2+2+4        ==1+1+2     4
4+4            ==2+2
8                ==4

code:

#include<cstdio>
#include<algorithm>
using namespace std;
const int M=1e9;
int a[1000010];
int main()
{
	a[1]=1,a[2]=2;
	for(int i = 3; i < 1000010; i++)
	{
		if(i%2==1)
		a[i]=a[i-1];
		else
		a[i]=a[i-2]+a[i/2];
		a[i]=a[i]%M;
	}
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",a[n]);
	}
	return 0;
}
/*
1+1+1+1+1+1+1
1+1+1+1+1+2
1+1+1+2+2
1+1+1+4          7 
1+2+2+2
1+2+4

(1)+1+1+1+1+1+1+1   =2+2+2+2
(1)+1+1+1+1+1+2     =2+2+4
(1)+1+1+1+2+2       =4+4
(1)+1+1+1+4         =8
(1)+1+2+2+2
(1)+1+2+4
2+2+2+2    ==1+1+1+1
2+2+4      ==1+1+2     4
4+4        ==2+2
8          ==4
*/
/*
for(int i = 2; i < n; i*=2)
	{
		if(n/i>1)
		sum+=(n/i-1)
		sum=sum+n/i;
	}
	int a,b,c;
	a=n/2;
	b=n/4;
	c=a/b;
	sum=1+a+b+c;
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值