51NOD 1004 n^n的末位数字

链接: https://www.51nod.com/onlineJudge/questionCode.html#!problemId=1004

1004 n^n的末位数字

题目来源: Author Ignatius.L (Hdu 1061)
基准时间限制:1 秒 空间限制:131072 KB 分值: 5 难度:1级算法题

关键词: 快速幂模

Description

给出一个整数N,输出N^N(N的N次方)的十进制表示的末位数字。

Input

一个数N(1 <= N <= 10^9)

Output

输出N^N的末位数字

SampleInput

13

SampleOutput

3

Hint

Source

Analyze

这个是个 快速幂模 的模板题

Code

#include <cstdio>  
#include <algorithm>  
#include <iostream>  
#include <cstring>  
using namespace std;  
  
#define LL long long  
LL mod_pow(LL a, LL b, LL p)  
{  
    LL ans = 1;  
    while(b > 0)    {  
        if(b & 1) ans = (ans * a )  % p;  
        a = (a * a) % p;  
        b >>= 1;  
    }  
    return ans;  
}  
int main()  
{  
    LL n;  
    while(cin>>n)  
    {  
        cout << mod_pow(n, n, 10) << endl;  
    }  
  
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值