HDU4734 F(x)


F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6383    Accepted Submission(s): 2456


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
      
      
3 0 100 1 10 5 100
 

Sample Output
      
      
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
————————————————————————————————
题目的意思求0到B 有多少个经过计算F(x)不大于F(A)的有几个
思路:数位dp,2位数组表示到第len位为止,小于等于sum有多少个,dfs求解

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10001
using namespace std;
#define LL long long

int dp[20][30000];
int a[100];

int dfs(int len,int sum,bool limit)
{
    if(len<0)
        return sum>=0;
    if(sum<0)
        return 0;
    if(dp[len][sum]!=-1&&!limit)
        return dp[len][sum];
    int up=limit?a[len]:9;
    int ans=0;
    for(int i=0; i<=up; i++)
    {
        ans+=dfs(len-1,sum-i*(1<<len),limit&&i==up);
    }
    return limit?ans:dp[len][sum]=ans;
}

int solve(int y,int x)
{
    int sum=0;
    int tmp=1;
    while(y>0)
    {
        sum+=y%10*tmp;
        y/=10;
        tmp*=2;
    }

    int cnt=0;
    while(x>0)
    {
        a[cnt++]=x%10;
        x/=10;
    }
    return dfs(cnt-1,sum,1);
}

int main()
{
    int n,m;
    int T;
    int q=1;
    memset(dp,-1,sizeof dp);
    for(scanf("%d",&T); T--;)
    {
        scanf("%d%d",&m,&n);
        printf("Case #%d: %d\n",q++,solve(m,n));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值