poj 3723 Conscription // qdu - F

F - Conscription
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

明白了题意就很简单,就是求最大生成树,求法和最小生成树基本相同,我觉得最大的难点就是明白题意。。。。


最关键的一句: Notice that only one relationship can be used when collecting one soldier.

每一个人只能用一种关系,我首先想到的是一条通路,后来仔细想想树也符合,既然树符合,要让减去的给费用最大,不就是最大生成树的问题了、


过了之后又仔细想想,是不是只含有一个环的树也符合规则,还是我题意理解的不够透彻。。。。。。求大牛解答。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int f[20005];
struct node
{
	int x,y,cost;
};
int find(int x)
{
	if(x==f[x])
	return x;
	return f[x]=find(f[x]);
}
int merge(int a,int b)
{
	int t1,t2;
	t1=find(a);
	t2=find(b);
	if(t1!=t2)
	{
		f[t1]=t2;
		return 1;
	}
	return 0;
}
int cmp(node u,node v)
{
	return u.cost>v.cost;
}
int main()
{
	int i,test,n,m,r;
	long long int sum;
	node t;
	vector<node>q;
	scanf("%d",&test);
	while(test--)
	{
		getchar();
		scanf("%d %d %d",&n,&m,&r);
		sum=(n+m)*10000;
		q.clear();
		for(i=0;i<=n+m;i++)
		f[i]=i;
		for(i=0;i<r;i++)
		{
			scanf("%d %d %d",&t.x,&t.y,&t.cost);
			q.push_back(t);
		}
		sort(q.begin(),q.end(),cmp);
		for(i=0;i<q.size();i++)
		{
			t=q.at(i);
			if(merge(t.x,t.y+n))
			{
				sum-=t.cost;
			}
		}
		printf("%lld\n",sum);
	}
	
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值