HDU - 1394 Minimum Inversion Number 树状数组求逆序数

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19156    Accepted Submission(s): 11548


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L

把第一个移到最后,其实逆序数的变化只和第一个元素有关,减去第一个元素的逆序数,也就是减去0~n-1里比a【i】小的,也就是a【i】, 同时把这个元素移到最后面,会多出0~n-1里比a【i】的大的这么多个,也就是n-a【i】-1,模拟找一下最小值


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<set>
typedef long long ll;
using namespace std;
int f[5005],n;
int sum(int x)
{
	int sum=0;
	while(x>0)
	{
		sum+=f[x];
		x-=x&-x;
	}
	return sum;
}
int add(int x,int a)
{
	while(x<=n)
	{
		f[x]+=a;
		x+=x&-x;
	}
	return 0;	
} 
int main()
{
	int minn,k,i,a[5005],ans;
	while(~scanf("%d",&n))
	{
		ans=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		ans=0;
		memset(f,0,sizeof(f));
		for(i=n;i>=1;i--)
			{
				ans+=(sum(a[i]));//printf("haha%d\n",ans);
				add(a[i]+1,1);	
			}
		minn=ans;
		for(i=1;i<=n;i++)
		{	
			ans=ans+n-a[i]-1-a[i];
			minn=min(minn,ans);	
		}
		printf("%d\n",minn);
	}
 }


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值