PAT 1147 Heaps

54 篇文章 1 订阅

原文链接:我的个人博客

原题描述

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

考点

   树、后序遍历、堆

思路

  题目给定完全二叉树的层次遍历,要求判断给定的树满足的是最大堆、最小堆还是普通的二叉树。这一点判断可以在后序遍历中完成,如果根比子树大,将maxflag标记位置为true;如果根比子树小,将minflag标记置为true。当后序遍历结束时,判断如果maxflag和minflag均为true证明既有比父节点大的数,又有比父节点小的树。如果仅有maxflag为true,则时大根堆。如果仅有minflag为true,则为小根堆。

代码

#include <bits/stdc++.h>
using namespace std;
int v[1010],m,n;//测试行数,节点个数
bool minflag,maxflag;
void test(int root,vector<int>& post){//root是下标 
    if(root>n) return;
 
    if(root*2<=n){
        if(v[root*2]>v[root]) minflag = true;//存在孩子比根节点都大,最小堆 
        if(v[root*2]<v[root]) maxflag = true;//最大堆  
        test(root*2,post);//遍历左子树 
    }   
    if(root*2+1<=n){
        if(v[root*2+1]>v[root]) minflag = true;//存在孩子比根节点都大,最小堆 
        if(v[root*2+1]<v[root]) maxflag = true;//最大堆 
        test(root*2+1,post);//遍历右子树 
    }
    post.push_back(v[root]); 
}
int main(){
    scanf("%d%d",&m,&n);
    for(int i=0;i<m;i++){   
        for(int j=1;j<=n;j++) scanf("%d",&v[j]);
        minflag = false;
        maxflag = false;
        vector<int> post;
        test(1,post);
 
        if(minflag&&maxflag) printf("Not Heap\n");
        else if(minflag) printf("Min Heap\n");
        else if(maxflag) printf("Max Heap\n");
 
        printf("%d",post[0]);
        for(int j=1;j<post.size();j++) printf(" %d",post[j]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值