这周dp(POJ-2229)


Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 12612 Accepted: 5046

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

题目的意思就是给出一个数,把它表示成2的幂级数总共有多少种形式。

分析:

如果 n 是奇数,dp[n]=dp[n-1],因为相当于把"1"放入排列中;
如果 n 是偶数,(1) 当组合中含有"1",组合数就等于dp[n-1];
               (2) 当组合中不含"1",把组合中的每一个因子都除以二,刚好得到 n/2 的组合数,所以此时组合数就等于dp[n/2];
所以,当 n 是偶数的时候,dp[n]=dp[n-1]+dp[n/2].

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1000005];
int main()
{
    dp[0]=0; dp[1]=1; dp[2]=2;
    int i=3;
    while(i<=1000000){
        dp[i]=dp[i-1]; i++;
        dp[i]=(dp[i-1]+dp[i/2])%1000000000; i++;
    }
    int n;
    while(scanf("%d",&n)!=EOF){
        printf("%d\n",dp[n]);
    }return 0;
}

这周dp,感觉dp考察兴趣和智商。还是要努力!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值