HDU_2846_Repository(字典树)

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2664    Accepted Submission(s): 1045



Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 
题意:给定P个字符串,然后有Q个询问,每次询问给出一个字符串,问给定的P个串中有多少个串包含了它。
解析:可以利用字典树处理。把每个给出的串的所有子串都建立到字典树中去 ,注意的是,同一个单词中相同的子串不重复计算。
题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2846
代码清单:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 26;

struct trie{
    int point;   //计数
    int first;   //标记判断是否是同一个单词
    trie *next[MAX];

};

trie *root=new trie();

int p,n;
char s[MAX];

void createTrie(char *s,int pose){
    trie *p, *q;
    int len=strlen(s),pos;
    for(int i=0;i<len;i++){
        p=root;
        for(int j=i;j<len;j++){
            pos=s[j]-'a';
            if(p->next[pos]==NULL){
                q=new trie();
                q->point=1;
                q->first=pose;
                for(int k=0;k<MAX;k++)
                    q->next[k]=NULL;
                p->next[pos]=q;
                p=p->next[pos];
            }
            else if(p->next[pos]->first==pose){
                p=p->next[pos];
            }
            else{
                p->next[pos]->point++;
                p->next[pos]->first=pose;
                p=p->next[pos];
            }
        }
    }
}

int findTrie(char *s){
    trie *p=root;
    int len=strlen(s),pos;
    for(int i=0;i<len;i++){
        pos=s[i]-'a';
        if(p->next[pos]==NULL)
            return 0;
        p=p->next[pos];
    }
    return p->point;
}

void delTrie(trie *Root){
    for(int i;i<MAX;i++){
        if(Root->next[i]!=NULL)
            delTrie(Root->next[i]);
    }
    free(Root);
}

int main(){
    for(int i=0;i<MAX;i++)
        root->next[i]=NULL;
    scanf("%d",&p);
    for(int i=1;i<=p;i++){
        scanf("%s",s);
        createTrie(s,i);
    }
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%s",s);
        printf("%d\n",findTrie(s));
    }
    delTrie(root);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值