HDU_1285_确定比赛名次(拓扑排序)

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14762    Accepted Submission(s): 5902



Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
  
  
4 3 1 2 2 3 4 3
 

Sample Output
  
  
1 2 4 3
 
分析:拓扑排序,注意判重边。还有就是注意排列顺序,推荐用优先队列。
题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1285
代码清单:

#include<map>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef unsigned int uint;
typedef long long ll;
typedef unsigned long long ull;

const int maxv = 500 + 5;

int N,M;
int p,q,index;
int degree[maxv];
int sortGraph[maxv];
bool graph[maxv][maxv];

void init(){
    index=0;
    memset(graph,false,sizeof(graph));
    memset(degree,0,sizeof(degree));
}

void topSort(){
    for(int i=1;i<=N;i++){
        for(int u=1;u<=N;u++){
            if(degree[u]==0){
                degree[u]=-1;
                sortGraph[index++]=u;
                for(int v=1;v<=N;v++){
                    if(graph[u][v]) degree[v]--;
                }break; //保证题意输出顺序
            }
        }
    }
    for(int i=0;i<index;i++){
        if(i==index-1) printf("%d\n",sortGraph[i]);
        else printf("%d ",sortGraph[i]);
    }
}

int main(){
    while(scanf("%d%d",&N,&M)!=EOF){
        init();
        for(int i=0;i<M;i++){
            scanf("%d%d",&p,&q);
            if(!graph[p][q]){
                graph[p][q]=true;
                degree[q]++;
            }
        }
        topSort();
    }return 0;
}

优先队列:
#include<map>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef unsigned int uint;
typedef long long ll;
typedef unsigned long long ull;

const int maxv = 500 + 5;

int N,M;
int p,q,index;
int degree[maxv];
int sortGraph[maxv];
bool graph[maxv][maxv];

void init(){
    index=0;
    memset(graph,false,sizeof(graph));
    memset(degree,0,sizeof(degree));
}

void topSort(){
    priority_queue<int,vector<int>,greater<int> >que;
    while(!que.empty()) que.pop();
    for(int i=1;i<=N;i++){
        if(degree[i]==0)
            que.push(i);
    }
    while(!que.empty()){
        int u=que.top(); que.pop();
        sortGraph[index++]=u;
        for(int v=1;v<=N;v++){
            if(graph[u][v]){
                degree[v]--;
                if(degree[v]==0) que.push(v);
            }
        }
    }
    for(int i=0;i<index;i++){
        if(i==index-1) printf("%d\n",sortGraph[i]);
        else printf("%d ",sortGraph[i]);
    }
}

int main(){
    while(scanf("%d%d",&N,&M)!=EOF){
        init();
        for(int i=0;i<M;i++){
            scanf("%d%d",&p,&q);
            if(!graph[p][q]){
                graph[p][q]=true;
                degree[q]++;
            }
        }
        topSort();
    }return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值