TIANKENG’s restaurant

Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
11
6

此题是一个贪心问题存时间时应小心,用32位整数存储,下面附上代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct node
{
    int a,b,c;

}stu[10005];
int main()
{
    int m,n;
    scanf("%d",&m);
    while(m--)
    {
        int num[10005];
        mem(num,0);
        int a,b,c,d,s;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d:%d%d:%d",&s,&a,&b,&c,&d);//用32位整数存储数据
            stu[i].a=s;
            stu[i].b=a*60+b;
            stu[i].c=c*60+d;
            for(int j=stu[i].b;j<stu[i].c;j++)//判断两个时间之间有多少点存在存在一次加一次人数
                num[j]+=stu[i].a;
        }
        int maxx=0;
        for(int i=0;i<=1500;i++)//求人数最大值
            {
                if(maxx<num[i])
                    maxx=num[i];
            }
            printf("%d\n",maxx);
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值