PTA_6-4 另类堆栈(15 分)_单指针栈

6-4 另类堆栈(15 分)
在栈的顺序存储实现中,另有一种方法是将Top定义为栈顶的上一个位置。请编写程序实现这种定义下堆栈的入栈、出栈操作。如何判断堆栈为空或者满?
函数接口定义:

bool Push( Stack S, ElementType X );
ElementType Pop( Stack S );
其中Stack结构定义如下:
typedef int Position;
typedef struct SNode *PtrToSNode;
struct SNode {
ElementType Data; / 存储元素的数组 */
Position Top; /* 栈顶指针 */
int MaxSize; /* 堆栈最大容量 */
};
typedef PtrToSNode Stack;
注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果队列是空的,则Pop函数必须输出“Stack Empty”,并且返回ERROR。
裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define ERROR -1
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
typedef struct SNode *PtrToSNode;
struct SNode {
    ElementType *Data;  /* 存储元素的数组 */
    Position Top;       /* 栈顶指针       */
    int MaxSize;        /* 堆栈最大容量   */
};
typedef PtrToSNode Stack;

Stack CreateStack( int MaxSize )
{
    Stack S = (Stack)malloc(sizeof(struct SNode));
    S->Data = (ElementType *)malloc(MaxSize * sizeof(ElementType));
    S->Top = 0;
    S->MaxSize = MaxSize;
    return S;
}

bool Push( Stack S, ElementType X );
ElementType Pop( Stack S );

Operation GetOp();          /* 裁判实现,细节不表 */
void PrintStack( Stack S ); /* 裁判实现,细节不表 */

int main()
{
    ElementType X;
    Stack S;
    int N, done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while ( !done ) {
        switch( GetOp() ) {
        case push: 
            scanf("%d", &X);
            Push(S, X);
            break;
        case pop:
            X = Pop(S);
            if ( X!=ERROR ) printf("%d is out\n", X);
            break;
        case end:
            PrintStack(S);
            done = 1;
            break;
        }
    }
    return 0;
}

/* 你的代码将被嵌在这里 */
输入样例:

4
Pop
Push 5
Push 4
Push 3
Pop
Pop
Push 2
Push 1
Push 0
Push 10
End
输出样例:

Stack Empty
3 is out
4 is out
Stack Full
0 1 2 5

#include <stdio.h>
#include <stdlib.h>
#include<cstring>
#define ERROR -1
typedef int ElementType;
typedef enum {
    push, pop, end
} Operation;
/*typedef enum {
    false, true
} bool;*/
typedef int Position;
typedef struct SNode *PtrToSNode;
struct SNode {
    ElementType *Data;  /* 存储元素的数组 */
    Position Top;       /* 栈顶指针       */
    int MaxSize;        /* 堆栈最大容量   */
};
typedef PtrToSNode Stack;

Stack CreateStack(int MaxSize)
{
    Stack S = (Stack)malloc(sizeof(struct SNode));
    S->Data = (ElementType *)malloc(MaxSize * sizeof(ElementType));
    S->Top = 0;
    S->MaxSize = MaxSize;
    return S;
}

bool Push(Stack S, ElementType X)
{
    if (S->MaxSize == S->Top)
    {
        puts("Stack Full");
        return 0;
    }
    S->Data[S->Top++]=X;
    return 1;
}
ElementType Pop(Stack S)
{
    if (!S->Top)
    {
        puts("Stack Empty");
            return ERROR;
    }
    return S->Data[--S->Top];
}

Operation GetOp()
{
    char a[11];
    scanf("%s", a);
    //push, pop, end
    if (!strcmp("Push", a))
        return push;
    if (!strcmp("Pop", a))
        return pop;
    if (!strcmp("End", a))
        return end;
}
void PrintStack(Stack S)
{
    while (S->Top)
    {
        printf("%d ", S->Data[--S->Top]);
    }
    puts("");
}

int main()
{
    ElementType X;
    Stack S;
    int N, done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while (!done) {
        switch (GetOp()) {
        case push:
            scanf("%d", &X);
            Push(S, X);
            break;
        case pop:
            X = Pop(S);
            if (X != ERROR) printf("%d is out\n", X);
            break;
        case end:
            PrintStack(S);
            done = 1;
            break;
        }
    }
    return 0;
}
  • 0
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我理解了你的问题。那么,pta7-5 特殊堆的 C 语言实现如下: ```c #include <stdio.h> #include <stdlib.h> #define MAX_SIZE 100 // 定义特殊堆结构体 struct SpecialStack { int data[MAX_SIZE]; // 堆数据 int min[MAX_SIZE]; // 堆中的最小值 int top; // 堆顶部指针 }; // 初始化特殊堆 void initStack(struct SpecialStack *stack) { stack->top = -1; } // 判断特殊堆是否为空 int isEmpty(struct SpecialStack *stack) { return stack->top == -1; } // 判断特殊堆是否已满 int isFull(struct SpecialStack *stack) { return stack->top == MAX_SIZE - 1; } // 向特殊堆中添加元素 void push(struct SpecialStack *stack, int item) { if (isFull(stack)) { printf("特殊堆已满,无法添加元素!\n"); return; } // 添加元素到堆中 stack->data[++stack->top] = item; // 更新最小值 if (stack->top == 0) { stack->min[stack->top] = item; } else { int min = stack->min[stack->top - 1]; stack->min[stack->top] = item < min ? item : min; } } // 从特殊堆中弹出元素 int pop(struct SpecialStack *stack) { if (isEmpty(stack)) { printf("特殊堆为空,无法弹出元素!\n"); return -1; } // 取出堆顶部元素 int item = stack->data[stack->top--]; // 更新最小值 stack->min[stack->top + 1] = 0; return item; } // 获取特殊堆中的最小值 int getMin(struct SpecialStack *stack) { if (isEmpty(stack)) { printf("特殊堆为空,无法获取最小值!\n"); return -1; } return stack->min[stack->top]; } // 测试函数 int main() { // 创建特殊堆 struct SpecialStack stack; initStack(&stack); // 向特殊堆中添加元素 push(&stack, 3); push(&stack, 5); push(&stack, 2); push(&stack, 1); // 获取特殊堆中的最小值 printf("特殊堆中的最小值为:%d\n", getMin(&stack)); // 弹出特殊堆中的元素 printf("特殊堆中的元素依次为:"); while (!isEmpty(&stack)) { printf("%d ", pop(&stack)); } printf("\n"); return 0; } ``` 以上是特殊堆的 C 语言实现代码,你可以根据需要进行修改、调试和运行。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值