PTA_6-6 Deque(25 分)手动实现双端队列

6-6 Deque(25 分)
A “deque” is a data structure consisting of a list of items, on which the following operations are possible:
Push(X,D): Insert item X on the front end of deque D.
Pop(D): Remove the front item from deque D and return it.
Inject(X,D): Insert item X on the rear end of deque D.
Eject(D): Remove the rear item from deque D and return it. Write routines to support the deque that take O(1) time per operation.
Format of functions:

Deque CreateDeque();
int Push( ElementType X, Deque D );
ElementType Pop( Deque D );
int Inject( ElementType X, Deque D );
ElementType Eject( Deque D );
where Deque is defined as the following:
typedef struct Node *PtrToNode;
struct Node {
ElementType Element;
PtrToNode Next, Last;
};
typedef struct DequeRecord *Deque;
struct DequeRecord {
PtrToNode Front, Rear;
};
Here the deque is implemented by a doubly linked list with a header. Front and Rear point to the two ends of the deque respectively. Front always points to the header. The deque is empty when Front and Rear both point to the same dummy header. Note: Push and Inject are supposed to return 1 if the operations can be done successfully, or 0 if fail. If the deque is empty, Pop and Eject must return ERROR which is defined by the judge program.
Sample program of judge:

#include <stdio.h>
#include <stdlib.h>

#define ElementType int
#define ERROR 1e5
typedef enum { push, pop, inject, eject, end } Operation;

typedef struct Node *PtrToNode;
struct Node {
    ElementType Element;
    PtrToNode Next, Last;
};
typedef struct DequeRecord *Deque;
struct DequeRecord {
    PtrToNode Front, Rear;
};
Deque CreateDeque();
int Push( ElementType X, Deque D );
ElementType Pop( Deque D );
int Inject( ElementType X, Deque D );
ElementType Eject( Deque D );

Operation GetOp();          /* details omitted */
void PrintDeque( Deque D ); /* details omitted */

int main()
{
    ElementType X;
    Deque D;
    int done = 0;

    D = CreateDeque();
    while (!done) {
        switch(GetOp()) {
        case push: 
            scanf("%d", &X);
            if (!Push(X, D)) printf("Memory is Full!\n");
            break;
        case pop:
            X = Pop(D);
            if ( X==ERROR ) printf("Deque is Empty!\n");
            break;
        case inject: 
            scanf("%d", &X);
            if (!Inject(X, D)) printf("Memory is Full!\n");
            break;
        case eject:
            X = Eject(D);
            if ( X==ERROR ) printf("Deque is Empty!\n");
            break;
        case end:
            PrintDeque(D);
            done = 1;
            break;
        }
    }
    return 0;
}

/* Your function will be put here */
Sample Input:

Pop
Inject 1
Pop
Eject
Push 1
Push 2
Eject
Inject 3
End
Sample Output:

Deque is Empty!
Deque is Empty!
Inside Deque: 2 3

/*#include <stdio.h>
#include <stdlib.h>
#include<cstring>
#define ElementType int
#define ERROR 1e5
typedef enum {
    push, pop, inject, eject, end
} Operation;

typedef struct Node *PtrToNode;
struct Node {
    ElementType Element;
    PtrToNode Next, Last;
};
typedef struct DequeRecord *Deque;
struct DequeRecord {
    PtrToNode Front, Rear;
};//双重结构体*/
Deque CreateDeque()
{
    Deque p;
    p = (Deque)malloc(sizeof(struct DequeRecord));//队列开空间
    p->Front = (PtrToNode)malloc(sizeof(struct Node));//队列头部指向一个新地址
    p->Front->Last = NULL;//头为空
    p->Rear = p->Front;//头尾相等
    p->Rear->Next = NULL;//尾为空
    return p;
}
int Push(ElementType X, Deque D)
{
    struct Node* tmp;
    tmp = (struct Node*)malloc(sizeof(struct Node));//开新的节点
    if (!tmp)//无法开辟新的空间
        return 0;
    tmp->Element = X;//赋值
    if (D->Front == D->Rear)//队列为空
    {
        D->Front->Next = tmp;//头尾指针指向tmp
        tmp->Last = D->Front;//tmp头指针指向头部
        D->Rear = tmp;//tmp由rear取代
        tmp->Next = NULL;//尾部为空
        return 1;
    }
    //非空部分
    tmp->Next = D->Front->Next;//tmp尾指针=头部尾指针相同
    tmp->Last = D->Front;//tmp头指针指向头部
    D->Front->Next->Last = tmp;//头部下下一个的头指针=tmp;
    D->Front->Next = tmp;//头部尾指针=tmp
    return 1;
}
ElementType Pop(Deque D)
{
    //队列为空
    if (D->Front == D->Rear)
        return ERROR;
    //队列中只有一个元素
    int num = D->Front->Next->Element;
    struct Node* tmp = D->Front->Next;
    if (D->Front->Next == D->Rear)
    {
        D->Rear = D->Front;//头尾相等
        D->Rear->Next = NULL;//清空
        free(tmp);
        return num;
    }
    D->Front->Next->Next->Last = D->Front;//下下一个节点的头指针=头
    D->Front->Next = D->Front->Next->Next;//头尾指针=下下一个
    free(tmp);
    return num;
}
int Inject(ElementType X, Deque D)
{
    struct Node*
        tmp = (struct Node*)malloc(sizeof(struct Node));
    if (!tmp) return 0;
    tmp->Element = X;
    if (D->Front == D->Rear)
    {
        D->Front->Next = tmp;
        tmp->Last = D->Front;
        D->Rear = tmp;
        //tmp->Next = NULL;
        return 1;
    }//和头部插入一样
    D->Rear->Next = tmp;
    tmp->Last = D->Rear;
    tmp->Next = NULL;
    D->Rear = tmp;
    return 1;
}
ElementType Eject(Deque D)
{
    if (D->Front == D->Rear)
        return ERROR;
    int num = D->Rear->Element;
    struct Node* tmp = D->Rear;
    D->Rear = D->Rear->Last;
    D->Rear->Next = NULL;
    free(tmp);
    return num;

}
/*
Operation GetOp()
{
    char a[111];
    scanf("%s", a);
    //push, pop, inject, eject, end
    if (!strcmp("Push", a))
        return push;
    if (!strcmp("Pop", a))
        return pop;
    if (!strcmp("Inject", a))
        return inject;
    if (!strcmp("Eject", a))
        return eject;
    if (!strcmp("End", a))
        return end;
}
void PrintDeque(Deque D)
{
    while (D->Front != D->Rear)
    {

        printf("%d ", Pop(D));
    }
    puts("");
}

int main()
{
    ElementType X;
    Deque D;
    int done = 0;

    D = CreateDeque();
    while (!done) {
        switch (GetOp()) {
        case push:
            scanf("%d", &X);
            if (!Push(X, D)) printf("Memory is Full!\n");
            break;
        case pop:
            X = Pop(D);
            if (X == ERROR) printf("Deque is Empty!\n");
            break;
        case inject:
            scanf("%d", &X);
            if (!Inject(X, D)) printf("Memory is Full!\n");
            break;
        case eject:
            X = Eject(D);
            if (X == ERROR) printf("Deque is Empty!\n");
            break;
        case end:
            PrintDeque(D);
            done = 1;
            break;
        }
    }
    return 0;
}
*/

  • 4
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值