首发博客

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 31698 Accepted: 13859

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
解题思路: DP动态规划!一开始根本没有想到DP上去,后来看了人家的解题报告才发现用DP是有多简单。后来自己又照着代码推了一遍,相当于先用一个数组dp[]将某个数前有多少个数比它小记下来dp[i],再拿它和后面的数作比较,如果发现后一个比它大则dp[i+1]=dp[i]+1;依次推到最后,记录所有的数的dp[i];最后在输出dp[]中最大值!
后来我再写了一遍,AC了!
代码:
#include<stdio.h>
int a[1001],dp[1001];
int main()
{
int n,i,j,t=0;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<1001;i++)
dp[i]=1;
for(i=1;i<n;i++)
for(j=0;j<i;j++)
if(a[j]<a[i]&&dp[i]<=dp[j])
dp[i]=dp[j]+1;
for(i=0;i<n;i++)
if(t<dp[i])
t=dp[i];
printf("%d\n",t);
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值