poj 2506---Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7481 Accepted: 3658

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251
 
解题思路:打表+递推+大数;
 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define mx 2010
int ls[mx];
int s[260][mx];
int main()
{
	int n,i,j;
	memset(ls,0,sizeof(ls));//清空数组为下一次做准备
	memset(s,0,sizeof(s));
	s[0][0]=1;
	s[1][0]=1;
	for(i=2;i<=250;i++)
	{
		for(j=0;j<=mx;j++)//s[i]表示第i个数;s[i][j]表示第i个数的第j位数
			ls[j]=s[i-1][j]+s[i-2][j]*2;//将第i个数的每一位上的数用ls[]存起来
		for(j=0;j<mx;j++)//对ls[]做大数相加处理
		{
			ls[j+1]+=(ls[j]/10);
			ls[j]%=10;
		}
		for(j=0;j<=mx;j++)//处理后再赋值回s[i][]
			s[i][j]=ls[j];
		memset(ls,0,sizeof(ls));//再次清空数组ls[];
	}
	while(~scanf("%d",&n))
	{
		j=mx-1;
		while(s[n][j]==0)
			j--;
		for(;j>=0;j--)
			printf("%d",s[n][j]);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值