POJ-2506-Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9194 Accepted: 4372

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14

n=0的时候是1

#include <stdio.h>
#include<string.h>
using namespace std;
char sum[1010];
void f(char s1[], char s2[])
{
    int l1 = strlen(s1),l2=strlen(s2);
    memset(sum, 0,sizeof(sum));
    int len;
    if(l1>l2)len=l1;
    else len = l2;
    int ksum = 0,k = 0;
    for(int i = 0; i<=len;++i)
    {
        ksum = k;
        if(i<l1)ksum+=(s1[i]-'0');
        if(i<l2)ksum+=2*(s2[i]-'0');
        sum[i] = ksum%10+'0';
        k = ksum/10;
    }
    if(sum[len]=='0')sum[len] = '\0';
    else sum[len+1] = '\0' ;
    strcpy(sum,sum);
}
int main()
{
    int n;
    char s1[1000], s2[1000];
    char k1[] ={"3"};
    char k2[] ={"1"};
    while(~scanf("%d", &n))
    {
        if(n<=1)printf("1\n");
        else if(n==2)printf("3\n");
        else
        {
            strcpy(s1,k1);
            strcpy(s2,k2);
            for(int i = 3; i<=n; ++i)
            {
                f(s1, s2);
                strcpy(s2,s1);
                strcpy(s1,sum);
            }
            int len = strlen(s1);
            for(int i = len-1;i>=0;--i)printf("%c",s1[i]);
            printf("\n");
        }

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值