Problem Description
蓝色空间号和万有引力号进入了四维水洼,发现了四维物体--魔戒。
这里我们把飞船和魔戒都抽象为四维空间中的一个点,分别标为 "S" 和 "E"。空间中可能存在障碍物,标为 "#",其他为可以通过的位置。
现在他们想要尽快到达魔戒进行探索,你能帮他们算出最小时间是最少吗?我们认为飞船每秒只能沿某个坐标轴方向移动一个单位,且不能越出四维空间。
Input
输入数据有多组(数据组数不超过 30),到 EOF 结束。
每组输入 4 个数 x, y, z, w 代表四维空间的尺寸(1 <= x, y, z, w <= 30)。
接下来的空间地图输入按照 x, y, z, w 轴的顺序依次给出,你只要按照下面的坐标关系循环读入即可。
for 0, x-1
for 0, y-1
for 0, z-1
for 0, w-1
保证 "S" 和 "E" 唯一。
Output
对于每组数据,输出一行,到达魔戒所需的最短时间。
如果无法到达,输出 "WTF"(不包括引号)。
Example Input
2 2 2 2 .. .S .. #. #. .E .# .. 2 2 2 2 .. .S #. ## E. .# #. ..
Example Output
1 3
这道题还是当时六月份校赛的题目(汗... 那个时候确实不会什么DFS,BFS... 学了之后也一直懒得补这道题,不过这题很简单,,就是一个四维的BFS,不过我做的时候可谓一波三折2333,主要是变量太多了,我都给整混了,然后不停的debug... 差点怀疑人生(哈哈哈
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
const int N = 33;
typedef struct node
{
int i, j, l, r, step;
}Node;
char str[N][N][N][N];
bool map[N][N][N][N];
int x, y, z, w;
int xx[8] = {0,0,0,1,0,0,0,-1};
int yy[8] = {0,0,1,0,0,0,-1,0};
int zz[8] = {0,1,0,0,0,-1,0,0};
int ww[8] = {1,0,0,0,-1,0,0,0};
void BFS(int a, int b, int c, int d)
{
map[a][b][c][d] = 1;
queue<Node> q;
Node t, p;
t.i = a;
t.j = b;
t.l = c;
t.r = d;
t.step = 0;
q.push(t);
while(!q.empty())
{
t = q.front();
q.pop();
if(str[t.i][t.j][t.l][t.r] == 'E')
{
printf("%d\n", t.step);
return;
}
for(int k = 0; k < 8; k++)
{
p.i = t.i + xx[k];
p.j = t.j + yy[k];
p.l = t.l + zz[k];
p.r = t.r + ww[k];
if(p.i >= 0 && p.j >= 0 && p.l >= 0 && p.r >= 0 && p.i < x && p.j < y && p.l < z && p.r < w)
{
if(str[p.i][p.j][p.l][p.r] != '#' && !map[p.i][p.j][p.l][p.r])
{
p.step = t.step + 1;
q.push(p);
map[p.i][p.j][p.l][p.r] = 1;
}
}
}
}
printf("WTF\n");
}
int main()
{
while(~scanf("%d%d%d%d", &x, &y, &z, &w))
{
int a, b, c, d;
memset(map, 0, sizeof(map));
for(int i = 0; i < x; i++)
for(int j = 0; j < y; j++)
for(int l = 0; l < z; l++)
{
scanf("%s", str[i][j][l]);
for(int r = 0; r < w; r++)
{
if(str[i][j][l][r] == 'S')
{
a = i;
b = j;
c = l;
d = r;
break;
}
}
}
BFS(a, b, c, d);
}
return 0;
}