Max Sum Plus Plus m段连续子序列最大和

16 篇文章 0 订阅
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
 
 
6 8


算是最大连续子序列和的加强版吧

状态:dp[i][j]表示前j个元素组成i组子序列和的最大值

状态转移:dp[i][j] = max(dp[i][j-1], max(dp[i-1][k])) + a[j] ,注意这里 i-1 <= k >= j-1

但是 j <= n <= 10000000,而且m的范围不知道,所以很有可能超内存...

看了网上的做法,说用什么滚动数组?记录前一组的最大值,所以是不断更新的

#include <iostream>  
#include <algorithm>  
#include <cstdio>  
#include <cstring>

using namespace std;  
const int N = 1e6 + 3;

int dp[N], a[N], pre[N];  //pre数组记录前一段和的最大值

int main()  
{      
    int m, n;
    while(~scanf("%d%d", &m, &n))
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        memset(pre, 0, sizeof(pre));
        dp[0] = 0;
        int p;
        for(int i = 1; i <= m; i++)
        {
            p = -1e9;
            for(int j = i; j <= n; j++)  //这里j一定要从i开始,因为每一组的元素数量肯定至少是1...
            {
                dp[j] = max(dp[j-1], pre[j-1]) + a[j];
                pre[j-1] = p;  //记录下来,为i+1组使用,使用后更新,为下一组使用
                p = max(p, dp[j]);
            }
        }
        printf("%d\n", p);
    }
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值