Seek the Name, Seek the Fame next数组的应用

7 篇文章 0 订阅
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5


题目大意:求一个字符串前后缀相等的长度。很明显,最大长度是next[len],然后不断的取next就得到了全部前后缀相等的长度。在运行时发现我的next数组含义有点不一样,因为我比较的是s[j + 1] == s[i],所以next[j]是坐标,加一后才是长度

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
const int N = 4e5 + 3;

char s[N];
int next[N];

void GetNext()
{
    int j = -1, len = strlen(s);
    next[0] = -1;
    for(int i = 1; i < len; i++)
    {
        while(j != -1 && s[j + 1] != s[i])
            j = next[j];
        if(s[j + 1] == s[i]) j++;
        next[i] = j;
    }
}
int main()
{
    while(~scanf("%s", s))
    {
        GetNext();
        int i = strlen(s) - 1, k = 0, m[N];
        while(next[i] != -1)
        {
            m[k++] = next[i];
            i = next[i];
        }
        for(i = k - 1; i >= 0; i--)
            printf("%d ", m[i] + 1);
        printf("%d\n", strlen(s));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值