For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
number zero on it.
Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
这道题算是上一题的加强版,这里是对每一个i求它之前的power strings,所以就是比之前多一个循环
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1e6 + 3;
char s[N];
int n, next[N];
void GetNext()
{
int j = -1;
next[0] = -1;
for(int i = 1; i < n; i++)
{
while(j != -1 && s[j + 1] != s[i])
j = next[j];
if(s[j + 1] == s[i]) j++;
next[i] = j;
}
}
int main()
{
int k = 1;
while(~scanf("%d", &n) && n)
{
scanf("%s", s);
GetNext();
printf("Test case #%d\n" , k++);
for(int i = 2; i <= n; i++)
{
if(i % (i - next[i - 1] - 1) == 0 && i / (i - next[i - 1] - 1) > 1)
printf("%d %d\n", i, i / (i - next[i - 1] - 1));
}
printf("\n");
}
return 0;
}