PAT A1025 Ranking(排序***重要)

1025 PAT Ranking (25分)

Note: 

  1. 使用sort进行排序时,需要提供cmp函数实现的排序规则。详见https://mp.csdn.net/console/editor/html/104351662
  2. strcmp函数是string.h头文件下用来比较两个char型数组的字典序大小的,其中strcmp(str1,str2)当str1的字典序小于str2时返回一个负数,当str1的字典序等于str2时返回0,当str1的字典序大于str2时返回一个正数。
  3. cmp函数中的strcmp(a.name, b.name)< 0 字符数组 ,因字符数组不可以直接进行比较,使用strcmp(a.name, b.name)<0表示a.name的字典序小于b.name的字典序。需要注意strcmp的返回值不一定是+-1,因此return strcmp(a.name, b.name)==-1/+1的写法是错误的。

题意:

有n个考场,每个考场有若干数量的考生。现在给出各个考场中的考生准考证号和分数,要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号以及考场内排名。

思路:

在结构体类型Student中存放题目要求的信息(准考证号、分数、考场号、考场内排名)根据题目要求需要写一个排序函数cmp,规则如下:

1、当分数不同时,按分数从大到小排序。2、否则按准考证号从小到大排序

算法本体分为下面三个部分:

步骤1:按考场读入各考生的信息,并对当前读入考场的所有考生进行排序。之后将该考场的所有考生的排名写入它们的结构体中。

步骤2:对所有考生进行排序。

步骤3:按顺序一边计算总排名,一边输出所有考生的信息。

 

原题:

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct Student{
	char id[15];//准考证号
	int score;//分数
	int location_number;//考场号
	int local_rank;//考场内排名
}stu[30010];
bool cmp(Student a, Student b){
	if(a.score != b.score)
		return a.score > b.score;//先按分数从高到低排序
	else
		return strcmp(a.id, b.id) < 0;//分数相同按准考证号从小到大排序
}
int main(){
	int i, j, n, k, num = 0; //num为总考生数
	cin >> n;   //n为考场数

	for(i = 1; i <= n; i++){
		cin >> k;  //该考场内人数
		for(j = 0; j < k; j++){
			cin >> stu[num].id >> stu[num].score;//输入准考证号和分数
			stu[num].location_number = i;    //该考生的考场号为i
			num ++;                          //总考生数加1
		}

		sort(stu + num - k, stu + num, cmp);//将该考场的考生排序
		
/*  用sort排序后考生顺序是对的,但是local_rank考场排名没有标记在每名考生的结构体中    */
		stu[num - k].local_rank = 1;        //该考场第1名的local_rank记为1
		for(j = num - k + 1; j < num; j++){   //对该考场剩余的考生
			if(stu[j].score == stu[j - 1].score)//如果与前一位考生同分,local_rank也相同
				stu[j].local_rank = stu[j - 1].local_rank;
			else                                //如果与前一位考生不同分,local_rank为该考生前的人数
				stu[j].local_rank =  j + 1 - (num - k);
		}
	}



	cout << num << endl; //输出总考生数
	sort(stu, stu + num, cmp); //将所有考生排序
	int r = 1;   //当前考生的排名
	for(i = 0; i < num; i++){
		if(i > 0 && stu[i].score != stu[i - 1].score)
			r = i + 1;   //当前考生与上一个考生分数不同时,让r更新为人数+1
		printf("%s ", stu[i].id);
		printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
	}
		
	system("pause");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值